Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Driver Issues -> 2.6.20.1 HD-5500 Digital Tuning Failure
Post new topic  Reply to topic View previous topic :: View next topic 
2.6.20.1 HD-5500 Digital Tuning Failure
PostPosted: Mon Feb 26, 2007 10:54 pm Reply with quote
kbocek
 
Joined: 11 Jan 2007
Posts: 10




I just upgraded to kernel 2.6.20.1 and my HD-5500 now can't seem to tune to any digital channels. The analog channels are working fine so I know the cable is connected.

MythTV's autoscanning and dtvscan both can't find any of the unencrypted QAM-256 channels that I could tune with the 2.6.18.6 drivers.

I don't know if it's related, but I'm also now having to manually modprobe the lgdt330x driver whereas it was automatically being loaded under 2.6.18.6.

Here are the load messages:

Code:
cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV
[card=47,autodetected]
TV tuner 64 at 0x1fe, Radio tuner -1 at 0x1fe
cx88[0]/2: cx2388x 8802 Driver Manager
ACPI: PCI Interrupt 0000:07:04.2[A] -> GSI 17 (level, low) -> IRQ 17
cx88[0]/2: found at 0000:07:04.2, rev: 5, irq: 17, latency: 160, mmio:
0xdc000000
cx2388x alsa driver version 0.0.6 loaded
ACPI: PCI Interrupt 0000:07:04.1[A] -> GSI 17 (level, low) -> IRQ 17
cx88[0]/1: CX88x/0: ALSA support for cx2388x boards
cx2388x v4l2 driver version 0.0.6 loaded
ACPI: PCI Interrupt 0000:07:04.0[A] -> GSI 17 (level, low) -> IRQ 17
cx88[0]/0: found at 0000:07:04.0, rev: 5, irq: 17, latency: 160, mmio:
0xda000000
tuner 1-0043: chip found @ 0x86 (cx88[0])
tda9887 1-0043: tda988[5/6/7] found @ 0x43 (tuner)
tuner 1-0061: chip found @ 0xc2 (cx88[0])
tuner 1-0061: type set to 64 (LG TDVS-H06xF)
tuner 1-0061: type set to 64 (LG TDVS-H06xF)
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0


And after manually loading lgdt330x and cx88-dvb:

Code:
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 0 (LG Electronics LGDT3303 VSB/QAM Frontend)...


Help me xyzzy, you're my only hope!

Smile

Thanks,
Kirk Bocek
View user's profile Send private message
PostPosted: Tue Feb 27, 2007 6:02 pm Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




If you just modprobe cx88-dvb after booting, and not lgdt330x, does cx88-dvb load? lgdt330x should be automatically loaded when cx88-dvb is.
View user's profile Send private message
PostPosted: Tue Feb 27, 2007 6:43 pm Reply with quote
kbocek
 
Joined: 11 Jan 2007
Posts: 10




Nope. I was getting errors until I started manually loading lgdt330x before cx88-dvb.
View user's profile Send private message
PostPosted: Wed Feb 28, 2007 1:54 am Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




What errors do you get when you try to load cx88-dvb before lgdt330x? And what version of module-init-tools do you have? /sbin/modprobe -V to check.
View user's profile Send private message
PostPosted: Wed Feb 28, 2007 9:25 am Reply with quote
kbocek
 
Joined: 11 Jan 2007
Posts: 10




In the ringbuffer:

Code:
cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
cx88[0]/2: cx2388x 8802 Driver Manager
ACPI: PCI Interrupt 0000:07:04.2[A] -> GSI 17 (level, low) -> IRQ 17
cx88[0]/2: found at 0000:07:04.2, rev: 5, irq: 17, latency: 160, mmio: 0xdc000000
cx2388x dvb driver version 0.0.6 loaded
cx8802_register_driver() ->registering driver type=dvb access=shared
CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47]
cx88[0]/2: cx2388x based dvb card
DVB: Unable to find symbol lgdt330x_attach()
cx88[0]: frontend initialization failed
cx8802_dvb_probe dvb_register failed err = -1
cx8802_register_driver() ->probe failed err = -1


These errors go away if I manually modprobe lgdt330x. And at the console:

Code:
FATAL: Error inserting cx88_dvb (/lib/modules/2.6.20.1smp-beryl-05/kernel/drivers/media/video/cx88/cx88-dvb.ko): No such device


This is a CentOS 4.4 x86_64 host.

Code:
$modprobe -V
module-init-tools version 3.1-pre5
$rpm -q module-init-tools
module-init-tools-3.1-0.pre5.3.2


Thanks for your help with this xyzzy. I appreciate it.

Kirk Bocek
View user's profile Send private message
PostPosted: Wed Feb 28, 2007 1:35 pm Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




kbocek wrote:

Code:

DVB: Unable to find symbol lgdt330x_attach()
module-init-tools version 3.1-pre5



There is the problem and the cause. A new method of dynamicly loading needed drivers went into 2.6.19, but it needs module-init-tools 3.2. There is a bug in 3.1 (which is a few years old) that keeps it from working. The command modprobe symbol:lgdt330x_attach should load the lgdt330x driver, but it won't work if you try it until you upgrade module-init-tools.
View user's profile Send private message
PostPosted: Wed Feb 28, 2007 1:43 pm Reply with quote
kbocek
 
Joined: 11 Jan 2007
Posts: 10




I guess my problem is trying to get this to work on a stodgy old distro like RHEL. I'll try to hunt down the correct module-init-tools.

Thanks again for looking at this. I really appreciate it.

Kirk Bocek

Update:

I downloaded the Fedora Core 5 source RPM module-init-tools-3.2.2-0.FC5.3.src.rpm and rebuilt it for my system. After updating with the resulting binary RPM. I updated my /etc/rc.d/rc.local with

Code:
modprobe symbol:lgdt330x_attach
modprobe cx88-dvb


and the MythTV channel scanner now finds the missing channels.

Many thanks.
View user's profile Send private message
2.6.20.1 HD-5500 Digital Tuning Failure
  pcHDTV Forum Index -> Driver Issues
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin