Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> HD-2000/3000 drivers -> Does anyone have HD3000 analog working on the 2.6.19 kernel?
Post new topic  Reply to topic View previous topic :: View next topic 
Does anyone have HD3000 analog working on the 2.6.19 kernel?
PostPosted: Sun Mar 11, 2007 6:48 pm Reply with quote
Bigchris
 
Joined: 18 Apr 2006
Posts: 15




I'm building a fc6 Mythtv system with a 2.6.19 kernel and while the HD3000 digital side works fine, I can't get the analog side to report in for duty. I've two HD3000s, cx8800 is loaded and they do create /dev/video0 and video1 and they do appear to setup in analog options in mythsetup but when I switch to mythfrontend it doesn't see the analog tuners and they won't play in Watch TV. Has anyone got these guys working with a 2.6.19 kernel?
View user's profile Send private message
Try latest v4l-dvb hg/CVS
PostPosted: Sun Mar 11, 2007 9:44 pm Reply with quote
inkling
 
Joined: 05 Feb 2004
Posts: 342




Install mercurial and go to linuxtv.org:

http://www.linuxtv.org

hg clone http://linuxtv.org/hg/v4l-dvb

This will give you the latest DVP API code.

If it still doesn't work, then you have something to chat about with the DVP API developers.

Good Luck!

-ink
View user's profile Send private message
PostPosted: Sun Mar 11, 2007 10:34 pm Reply with quote
Bigchris
 
Joined: 18 Apr 2006
Posts: 15




Thanks Ink,
I'm not a software type so some of what you told me went over my head, but I need a new direction and I'll persue it as an educational opportunity. Smile
Best regards,
Chris
View user's profile Send private message
Update
PostPosted: Mon Mar 12, 2007 12:22 am Reply with quote
Bigchris
 
Joined: 18 Apr 2006
Posts: 15




Well see I'm smarter already! Tvtime works with both of my HD3000 analog tuners so that makes it Mythtv vs V4l-dvb argument, and it could be argued that the V4l-dvb part is working! Wink
View user's profile Send private message
similar problem but not similar solution
PostPosted: Wed May 23, 2007 7:19 pm Reply with quote
mucm
 
Joined: 02 Oct 2004
Posts: 3




I also have a similar problem getting analog working, although I have digital working fine (pchdtv-3000).

When I "modprobe cx8800" the /dev/video0 shows up (actually /dev/v4l/radio0 v4l/vbi0 and v4l/video0 show up and /dev/video0 shows up as a soft link). Do I also have to unload the cx88_dvb, cx8802 or any other modules before I load the cx8800 module?

Also, Bigchris' resolution of trying it with tvtime didn't work for me (and I know I've got my tvtime using the right NTSC frequency table). All channels including known strong local channels just say "No signal" when I tune to them with tvtime. Also tvtime-scanner finds "No signal" for all frequencies it scans.

I'm using gentoo's kernel 2.6.20-r8, and I've previously had the same problem on 2.6.19-r5.

Is there a particular patch or version, inkling, that contains a fix for this problem? Or is this "the latest version can't hurt" theory?

Also, inkling, what is DVP? A typo of DVB?

Thanks in advance, inkling, or anyone else that can shed some light here.

Martin
View user's profile Send private message
PostPosted: Wed Jul 08, 2015 4:07 am Reply with quote
Nuzzle
 
Joined: 08 Jul 2015
Posts: 5




In order to get it working on the regular kernel, I had to remove any mention of dvb and video from the lib/lib64 directories, download the 5500 driver, make, make install and all was well. I try the same thing with the smp kernel and I get the analog device just fine, but never any /dev/dvb. We offer best quality Electronic Gadgets test papers and Text books and Islamic Apps materials. You can get our Games 100% guaranteed Islamic Devices. Looks like the correct stuff is loaded into /lib/modules/2.6.17-1.2142_FC4smp/kernel/drivers/media/video/ and /lib/modules/2.6.17-1.2142_FC4smp/kernel/drivers/media/dvb/ (by comparing the file names to the modules that are working in my other kernel). Any advice on getting this to work or any known issues with smp as to why it wouldn't work?
View user's profile Send private message
Does anyone have HD3000 analog working on the 2.6.19 kernel?
  pcHDTV Forum Index -> HD-2000/3000 drivers
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin