Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> Horrible Interlacing in analog NTSC capture
Post new topic  Reply to topic View previous topic :: View next topic 
Horrible Interlacing in analog NTSC capture
PostPosted: Fri Nov 30, 2007 6:46 pm Reply with quote
NicholasAZ
 
Joined: 30 Nov 2007
Posts: 2




I've tried watching analog NTSC cable, but the interlacing is so bad it's almost unwatchable.

It happens when any object moves on the screen in front of the background.. It's like it goes through a mozzarella cheese shreeder....

Someone please tell me how to fix this... It's so bad I'm thinking about returning the card for something that captures analog TV respectably well...

I've tried xawtv but it kind of sucks as far as options go, so then I used mplayer. Here is the command I use:

Code:
mplayer tv:// -tv driver=v4l2:chanlist=us-cable:alsa:adevice=hw.1,0:amode=1: audiorate=48000:forceaudio:volume=100:immediatemode=0: buffersize=16:norm=NTSC-M


I've tried doing post processing to get rid of the horrible motion-based interlacing, with a little bit success, but it uses up 80% of my CPU!!! Just to get it looking respectable... and with post processing it reduces overall information, so it's not ideal..

Code:
 mplayer -vf eq2,spp=6,hqdn3d,pp=l5


If you want I can take a screenshot of the interlacing/striping, whatever to call it, and post it to google picasa or something... But I think alot of people here probably know what I'm talking about.

So please, someone familiar with this issue please help me!! I am so sad right now with bad analogue TV... Sad
View user's profile Send private message
PostPosted: Fri Nov 30, 2007 7:30 pm Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




It has nothing to do with the card, that's just how analog tv is. Try a deinterlacing filter, like yadif. tvtime also has a bunch of de-interlacing filters.
View user's profile Send private message
PostPosted: Fri Nov 30, 2007 8:11 pm Reply with quote
NicholasAZ
 
Joined: 30 Nov 2007
Posts: 2




xyzzy wrote:
It has nothing to do with the card, that's just how analog tv is. Try a deinterlacing filter, like yadif. tvtime also has a bunch of de-interlacing filters.


Thanks alot !!! yadif works awesomely... I tried tvtime (thanks again), but although it deinterlaces, it doesn't denoise, so there's alot of noisey things. Previously I was using the pp=l5 deinterlacer, which was described as a low pass deinterlacing filter... Didn't work well. Yadif is superb.

Code:
       yadif=[mode[:field_dominance]]
              Yet another deinterlacing filter
                 <mode>
                      0: Output 1 frame for each frame.
                      1: Output 1 frame for each field.
                      2: Like 0 but skips spatial interlacing check.
                      3: Like 1 but skips spatial interlacing check.
                 <field_dominance>
                      Operates like tfields.


I use 0, because any other option sends my cpu to 100%, and 0 only uses 16%. (3Ghz Core 2 duo, 2MB cache)...

I also stopped using hqdn3d and now I use denoise3d, which uses less cpu..

so this is my mplayer command and it works great!! Looks like a regular TV finally!! High powered CPU reccomended.

Code:
mplayer -vf eq2,spp=6,denoise3d,yadif=0 tv:// -tv driver=v4l2:chanlist=us-cable: alsa:adevice=hw.1,0:amode=1:audiorate=48000:forceaudio:volume=100:immediatemode=0: buffersize=16:norm=NTSC-M
View user's profile Send private message
Horrible Interlacing in analog NTSC capture
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin