Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> noisy analog audio in myth
Post new topic  Reply to topic View previous topic :: View next topic 
noisy analog audio in myth
PostPosted: Wed Nov 21, 2007 9:06 pm Reply with quote
frank10
 
Joined: 12 Oct 2007
Posts: 5




my pchdtv5500 is working great with mythtv. all works except the audio on analog/ntsc channels sounds awful. there is some type of noise being introduced somehow. any suggestions on how to fix it?
________
No2 vaporizer


Last edited by frank10 on Tue Feb 22, 2011 9:33 pm; edited 1 time in total
View user's profile Send private message
PostPosted: Sun Nov 25, 2007 8:47 am Reply with quote
Malamber
 
Joined: 25 Nov 2007
Posts: 1




I have the same issue. Sound is perfect on ATSC stations, but it's terrible on NTSC. There's almost a high pitch sound as well as an echo effect.

This is also under Myth. I have no clue how to check analog sound otherwise.
View user's profile Send private message
PostPosted: Sun Nov 25, 2007 9:16 am Reply with quote
frank10
 
Joined: 12 Oct 2007
Posts: 5




At first, I couldn't get any sound and then I changed the audio settings for the analog portion to dsp1. now I'm still getting the odd sound.
________
Suzuki katana ay50


Last edited by frank10 on Tue Feb 22, 2011 9:33 pm; edited 1 time in total
View user's profile Send private message
PostPosted: Sun Nov 25, 2007 7:20 pm Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




If you're capturing sound directly from the card with ALSA, don't use the audio patch cable.
View user's profile Send private message
PostPosted: Sun Nov 25, 2007 9:54 pm Reply with quote
frank10
 
Joined: 12 Oct 2007
Posts: 5




no patch cable being used
________
Herbal vaporizer


Last edited by frank10 on Tue Feb 22, 2011 9:34 pm; edited 1 time in total
View user's profile Send private message
PostPosted: Mon Nov 26, 2007 6:06 am Reply with quote
frank10
 
Joined: 12 Oct 2007
Posts: 5




should I try a fixed sampling rate or disable volume control?
________
Essential Vaaapp


Last edited by frank10 on Tue Feb 22, 2011 9:34 pm; edited 1 time in total
View user's profile Send private message
PostPosted: Fri Dec 07, 2007 1:57 pm Reply with quote
someone777
 
Joined: 28 Oct 2007
Posts: 6




Try setting the sample rate to 48000. It worked for me.
View user's profile Send private message
PostPosted: Thu Dec 13, 2007 5:22 pm Reply with quote
suid77
 
Joined: 13 Dec 2007
Posts: 1




Malamber wrote:
I have the same issue. Sound is perfect on ATSC stations, but it's terrible on NTSC. There's almost a high pitch sound as well as an echo effect.

This is also under Myth. I have no clue how to check analog sound otherwise.


Same issue for me too. ATSC works perfectly, NSTC video is fine but there's a high pitch echo on the audio which makes it unusable. No patch cable, and I tried every possible sampling rate. Audio elsewhere is fine (music, DVDs, ATSC TV) only NTSC TV has the issue.

Originally I was using 2.6.23 kernel, tried 2.6.24-rc5 and nothing changed. (I was hopeful because there are numerous cx88-alsa driver patches from xyzzy in it, but no luck Sad )

system specs: Gentoo linux (2.6.24_rc5) on AMD64 3200+ / 1g ram / via chipset mobo / via 82xx sound / NVidia 6600 GT AGP

any ideas?

Edit: I tossed mythbuntu on the box last night and saw [heard] exactly the same high pitched noise and echo. Is this a hardware issue? Or did something change in the newer kernels ( >=2.6.22 )?
View user's profile Send private message
Same Noisy analog problem.
PostPosted: Sun Dec 16, 2007 9:24 pm Reply with quote
fuqqer
 
Joined: 16 Dec 2007
Posts: 2




I have the same exact problem. My HD(ATSC) sound is great. My NTSC sound has some high pitch scratch. Ugh. That combined with the reception quality of ntsc makes me want to return this thing after 4 days of fiddling.
________
LEXUS F HISTORY


Last edited by fuqqer on Wed Feb 23, 2011 6:56 pm; edited 1 time in total
View user's profile Send private message
PostPosted: Mon Dec 17, 2007 11:36 am Reply with quote
fuqqer
 
Joined: 16 Dec 2007
Posts: 2




If you're using mythtv, the sampling settings need to be set at BOTH locations, the backend and the frontend.

From the backend:
Run mythtv-setup,
Add your pchdtv5500 as a dvb card
Make sure you enter the analog settings dialog and change the sampling rate to 48000.
Also make sure that you have the proper audio device set. If you type the device in manually, the setting will not hold, you need to select it from the available options!

The audio device you use depends on how you're detecting cx88_alsa driver in your modprobe settings (distro dependent) in /etc. I have options cx88-alsa index=2,3 so this means the audio on the first pchdtv5500 is recognized as /dev/dsp2. This does NOT mean your /dev/video0 has changed or that /dev/vbi0 has changed.

From the frontend menu in myth:

Utilities/setup->setup->tv settings->recording profiles->software encoders(v4l)->Live TV

Hit next a few times and adjust the sampling rate as needed.
________
OXYGEN VAPORIZER
View user's profile Send private message
noisy analog audio in myth
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin