Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> xine-hd -> Xine doesn't know how to handel dtv://
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
Xine doesn't know how to handel dtv://
PostPosted: Sat Feb 05, 2005 11:40 am Reply with quote
SpikeyGG
Guest
 




Hello all,

I'm trying to get xine working on my new system. I am running the AMD64 port of Debian and the compile/configure seems to go correctly with Xine. However, when I start it up there is no DTV button. I only have buttons for VCD, DVD, DVB, and CD. When I try to run "xine dtv://" it complains:
"-xine engine error- There is no input plugin available to handle 'dtv://'. Maybe MRL syntax is wrong or file/stream source doesn't exist."

I looked in /usr/local/lib/xine/plugins/1.0.0/ and I see a xineplug_inp_dtv.so so I think it's set up correctly but there must be a broken link somewhere between the xine lib and xine ui. I think the problem is that Debian has some xine libraries already installed and unfortunately, I cannot uninstall them because Debian thinks they are required for X. Is there anyway I can force Xine to see the DTV plugin?

Thanks,

-Greg
PostPosted: Sat Feb 05, 2005 12:24 pm Reply with quote
Scott Larson
 
Joined: 15 Oct 2003
Posts: 713
Location: Portland, OR




This message really means "Couldn't open /dev/dtv". For some reason this list of possible causes doesn't include "already open by another process" which is usually what causes it on my system.
View user's profile Send private message
PostPosted: Sat Feb 05, 2005 12:47 pm Reply with quote
SpikeyGG
Guest
 




I don't think that it's already in use, because if I don't have anything else running I can use getatsc to dump a stream to a file, then load that file with xine and it works fine.

When I run "xine /dev/dtv" It complains:

- xine engine error -
There is no demuxer plugin available to handle '/dev/dtv'
Usually this means that the file format was not recognized.

So it looks like it can't handle dtv but it works fine with a TS file. I don't know what the deal is. Anyone?

Thanks,

-Greg
PostPosted: Tue Feb 08, 2005 4:20 pm Reply with quote
Scott Larson
 
Joined: 15 Oct 2003
Posts: 713
Location: Portland, OR




In the past I've had trouble getting new versions of xine to find the right versions of plug-ins if there were old versions of the libraries and plug-ins still around. The only way I was able to get xine-hd to work was to go into /usr/local/lib and wipe out absolutely everything with xine in its name. I think it was finding the old plug-ins, seeing that their versions weren't right and complaining the plug-in didn't exist even though there were at least two versions of it.
View user's profile Send private message
PostPosted: Wed Feb 09, 2005 7:38 pm Reply with quote
Scott Larson
 
Joined: 15 Oct 2003
Posts: 713
Location: Portland, OR




Also, start xine with --verbose=8. That will print the paths to all the plug-ins it's finding.
View user's profile Send private message
Xine doesn't know how to handel dtv://
  pcHDTV Forum Index -> xine-hd
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin