Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> mythTV wiith the HD-2000 card -> Unable to tune QAM channels
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
Unable to tune QAM channels
PostPosted: Fri May 27, 2005 4:02 pm Reply with quote
brucep
 
Joined: 28 Dec 2004
Posts: 12




Hi all,

Here's a rundown of what I have:

Fedora Core 3 w/ 2.6.12-rc3 kernel
WinTV PVR-350
HD-3000
mythtv 0.18.1

When running myth I can see video on the PVR-350 & the PVR's remote works great. myth also sees the HD-3000 as DVB device 0 in its setup.

If I manually test the HD-3000 using "azap -r 805" (with channel 805 properly defined in ~/.azap/channels.conf) I get a signal lock. I can then cat /dev/dvb/adapter0/dvr0 to an mpg file & play the file with mplayer.

However when I try to configure the HD-3000 within mythtv and do a channel scan it doesn't seem to find any channels. The console output when I run mythtv-setup looks something like this:

Quote:

Setting currenTID = 32
2005-05-27 18:57:03.400 DVB#0 DVB signal ef9c | snr fcfb | ber 0 | unc 0
2005-05-27 18:57:03.400 DVB#0 Status: LOCK.
Setting currenTID = 33
2005-05-27 18:57:08.763 DVB#0 Signal Lost
2005-05-27 18:57:09.271 DVB#0 Signal Locked
2005-05-27 18:57:09.963 DVB#0 DVB signal e394 | snr fc5b | ber 0 | unc 0
2005-05-27 18:57:09.963 DVB#0 Status: LOCK.
Setting currenTID = 34
2005-05-27 18:57:15.495 DVB#0 Signal Lost
2005-05-27 18:57:16.774 DVB#0 DVB signal 7cab | snr f0a3 | ber 0 | unc 0
2005-05-27 18:57:18.671 DVB#0 DVB signal 7686 | snr f4cd | ber 0 | unc 0
2005-05-27 18:57:20.940 DVB#0 DVB signal 7cab | snr f0a3 | ber 0 | unc 0
2005-05-27 18:57:21.242 DVB#0 WARNING - Status: NO LOCK!


I built mythtv with --enable-dvb --enable-dvb-eit --dvb-path=/lib/modules/2.6.12-rc3/build/include.

So what am I missing? With my luck it's probably something extremely simple that I'm completely overlooking...

-Bruce
View user's profile Send private message
Re: Unable to tune QAM channels
PostPosted: Sat May 28, 2005 10:08 am Reply with quote
mmorris1
Guest
 




brucep wrote:
Hi all,

Here's a rundown of what I have:

Fedora Core 3 w/ 2.6.12-rc3 kernel
WinTV PVR-350
HD-3000
mythtv 0.18.1

When running myth I can see video on the PVR-350 & the PVR's remote works great. myth also sees the HD-3000 as DVB device 0 in its setup.

If I manually test the HD-3000 using "azap -r 805" (with channel 805 properly defined in ~/.azap/channels.conf) I get a signal lock. I can then cat /dev/dvb/adapter0/dvr0 to an mpg file & play the file with mplayer.

However when I try to configure the HD-3000 within mythtv and do a channel scan it doesn't seem to find any channels. The console output when I run mythtv-setup looks something like this:

Quote:

Setting currenTID = 32
2005-05-27 18:57:03.400 DVB#0 DVB signal ef9c | snr fcfb | ber 0 | unc 0
2005-05-27 18:57:03.400 DVB#0 Status: LOCK.
Setting currenTID = 33
2005-05-27 18:57:08.763 DVB#0 Signal Lost
2005-05-27 18:57:09.271 DVB#0 Signal Locked
2005-05-27 18:57:09.963 DVB#0 DVB signal e394 | snr fc5b | ber 0 | unc 0
2005-05-27 18:57:09.963 DVB#0 Status: LOCK.
Setting currenTID = 34
2005-05-27 18:57:15.495 DVB#0 Signal Lost
2005-05-27 18:57:16.774 DVB#0 DVB signal 7cab | snr f0a3 | ber 0 | unc 0
2005-05-27 18:57:18.671 DVB#0 DVB signal 7686 | snr f4cd | ber 0 | unc 0
2005-05-27 18:57:20.940 DVB#0 DVB signal 7cab | snr f0a3 | ber 0 | unc 0
2005-05-27 18:57:21.242 DVB#0 WARNING - Status: NO LOCK!


I built mythtv with --enable-dvb --enable-dvb-eit --dvb-path=/lib/modules/2.6.12-rc3/build/include.

So what am I missing? With my luck it's probably something extremely simple that I'm completely overlooking...

-Bruce


Hello Bruce

I had the same problem.. MythTV scan fails to find any channels, although you know they are there.. I manually configured the mythconverg database to match the info found in ~/.azap/channnels.conf..
see previous link Posted: Thu May 26, 2005 7:21 am in another forum for futher details
http://www.pchdtv.com/forum/viewtopic.php?t=794

Regards Matthew
Re: Unable to tune QAM channels
PostPosted: Sat May 28, 2005 4:48 pm Reply with quote
brucep
 
Joined: 28 Dec 2004
Posts: 12




mmorris1 wrote:
I manually configured the mythconverg database to match the info found in ~/.azap/channnels.conf..
see previous link Posted: Thu May 26, 2005 7:21 am in another forum for futher details
http://www.pchdtv.com/forum/viewtopic.php?t=794

Regards Matthew


Thanks for the pointer. I already managed to figure out a number of QAM channels in my area (Comcast, Boston) using azap, dvbscan, etc. so I guess I'll have to figure out how to manually insert all that into the database.

-Bruce
View user's profile Send private message
Re: Unable to tune QAM channels
PostPosted: Sun May 29, 2005 11:43 am Reply with quote
brucep
 
Joined: 28 Dec 2004
Posts: 12




mmorris1 wrote:

I had the same problem.. MythTV scan fails to find any channels, although you know they are there.. I manually configured the mythconverg database to match the info found in ~/.azap/channnels.conf..
see previous link Posted: Thu May 26, 2005 7:21 am in another forum for futher details
http://www.pchdtv.com/forum/viewtopic.php?t=794


Matthew,

I've tried following the instructions in your other post but I'm not having a whole lot of luck. Here's whatI've tied to tune channel 802, which is WGBH-DT in the Boston area:

In my ~/.azap/channels.conf I have:
WGBH-DT:573000000:QAM_256:2432:2433

If I run azap -r WGBH-DT I can cat /dev/dvb/adapter0/dvr0 and pipe it to an mpg file or straight to mplayer and it works fine. While azap is running I run dvbscan and get the following:
Code:

[mythtv@mythtv-1 ~]$ dvbscan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x1ffb
dumping lists (11 services)
[0002]                   (0x0002) 00: PCR 0x0800          A 0x0801 0x0802 (spa)
[000b]                   (0x000b) 00: PCR 0x0840          A 0x0841 0x0842 (spa)
[0009]                   (0x0009) 00: PCR 0x0880          A 0x0881 0x0882 (spa)
[0008]                   (0x0008) 00: PCR 0x08c0          A 0x08c1 0x08c2 (spa)
[0003]                   (0x0003) 00: PCR 0x0900          A 0x0901 0x0902 (spa)
[0007]                   (0x0007) 00: PCR 0x0940          A 0x0941 0x0942 (spa)
[0001]                   (0x0001) 00: PCR 0x0980          A 0x0981 0x0982 (spa)
[000a]                   (0x000a) 00: PCR 0x09c0          A 0x09c1 0x09c2 (spa)
[0004]                   (0x0004) 00: PCR 0x0a00          A 0x0a01 0x0a02 (spa)
[000c]                   (0x000c) 00: PCR 0x0a40          A 0x0a41 0x0a42 (spa)
[0006]                   (0x0006) 00: PCR 0x0a80          A 0x0a81
Done.

Now this may be where I'm getting mixed up, but given that the PID's I have for WGBH-DT are 0x0980 and 0x0981 I think that the service ID I need to use in myth is 1 (since the lefthand column that corresponds to these PID's is [0001]). Is this correct?

So here's the entry I have in the database for this channel:
Code:

select * from channel where channum=802;
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+
| chanid | channum | freqid    | sourceid | callsign | name             | icon | finetune | videofilters | xmltvid | recpriority | contrast | brightness | colour | hue   | tvformat | commfree | visible | outputfilters | useonairguide | mplexid | serviceid | atscsrcid |
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+
|   2802 | 802     | 573000000 |        2 | WGBHDT   | WGBHDT (WGBH-DT) | none |     NULL |              | 28055   |           0 |    32768 |      32768 |32768 | 32768 | ATSC     |        1 |       1 |               |             0 |       7 |         1 |         0 |
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+

chanid is a unique value in the table.
channum is obvious.
freqid is the frequency from azap, channels.conf,etc.
sourceid corresponds to the correct entry in the videosourceid table.
callsign & name are correct as far as my channel data source goes.
xmltvid is correct.
mplexid corresponds to the correct entry in dvb_multiplex (see below).
service id is 1 from dvbscan output above.
Everything else is set to defaults.

Here's the mplexid row that the above is associated with:

Code:

mysql> select * from dtv_multiplex where mplexid=7;
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+
| mplexid | sourceid | transportid | networkid | frequency | inversion | symbolrate | fec  | polarity | modulation | bandwidth | lp_code_rate | transmission_mode | guard_interval | visible | constellation | hierarchy | hp_code_rate | sistandard | serviceversion | updatetimestamp     |
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+
|       7 |        2 |        NULL |      NULL | 573000000 | a         |       NULL | auto | NULL     | qam_256    | a         | auto         | a      | auto           |       0 | auto          | auto      | auto         | atsc       |             33 | 2005-05-27 18:28:56 |
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+


As soon as I start up mythbackend I see the following in the console window, and I'm unable to manually tune to channel 802:
Code:

2005-05-29 14:37:19.789 DVB#0 DVB SI Table Parser Started
2005-05-29 14:37:19.790 DVB#0 Using DVB card 0, with frontend pcHDTV HD3000 HDTV.
2005-05-29 14:37:20.056 DVB#0 DVB signal ef9c | snr fd13 | ber    0 | unc    0
2005-05-29 14:37:20.056 DVB#0 Status: LOCK.
2005-05-29 14:37:20.056 DVB#0 Multiplex Locked
2005-05-29 14:37:21.330 DVB#0 Successfully tuned to channel 802.
2005-05-29 14:37:21.330 DVB#0 ERROR - Channel #802 is off air.


So myth still seems to be having trouble tuning to this channel. Any idea what I might be missing or doing wrong here?

Thanks,

-Bruce
Code:
View user's profile Send private message
Re: Unable to tune QAM channels
PostPosted: Sun May 29, 2005 11:44 am Reply with quote
brucep
 
Joined: 28 Dec 2004
Posts: 12




mmorris1 wrote:

I had the same problem.. MythTV scan fails to find any channels, although you know they are there.. I manually configured the mythconverg database to match the info found in ~/.azap/channnels.conf..
see previous link Posted: Thu May 26, 2005 7:21 am in another forum for futher details
http://www.pchdtv.com/forum/viewtopic.php?t=794


Matthew,

I've tried following the instructions in your other post but I'm not having a whole lot of luck. Here's whatI've tied to tune channel 802, which is WGBH-DT in the Boston area:

In my ~/.azap/channels.conf I have:
WGBH-DT:573000000:QAM_256:2432:2433

If I run azap -r WGBH-DT I can cat /dev/dvb/adapter0/dvr0 and pipe it to an mpg file or straight to mplayer and it works fine. While azap is running I run dvbscan and get the following:
Code:

[mythtv@mythtv-1 ~]$ dvbscan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x1ffb
dumping lists (11 services)
[0002]                   (0x0002) 00: PCR 0x0800          A 0x0801 0x0802 (spa)
[000b]                   (0x000b) 00: PCR 0x0840          A 0x0841 0x0842 (spa)
[0009]                   (0x0009) 00: PCR 0x0880          A 0x0881 0x0882 (spa)
[0008]                   (0x0008) 00: PCR 0x08c0          A 0x08c1 0x08c2 (spa)
[0003]                   (0x0003) 00: PCR 0x0900          A 0x0901 0x0902 (spa)
[0007]                   (0x0007) 00: PCR 0x0940          A 0x0941 0x0942 (spa)
[0001]                   (0x0001) 00: PCR 0x0980          A 0x0981 0x0982 (spa)
[000a]                   (0x000a) 00: PCR 0x09c0          A 0x09c1 0x09c2 (spa)
[0004]                   (0x0004) 00: PCR 0x0a00          A 0x0a01 0x0a02 (spa)
[000c]                   (0x000c) 00: PCR 0x0a40          A 0x0a41 0x0a42 (spa)
[0006]                   (0x0006) 00: PCR 0x0a80          A 0x0a81
Done.

Now this may be where I'm getting mixed up, but given that the PID's I have for WGBH-DT are 0x0980 and 0x0981 I think that the service ID I need to use in myth is 1 (since the lefthand column that corresponds to these PID's is [0001]). Is this correct?

So here's the entry I have in the database for this channel:
Code:

select * from channel where channum=802;
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+
| chanid | channum | freqid    | sourceid | callsign | name             | icon | finetune | videofilters | xmltvid | recpriority | contrast | brightness | colour | hue   | tvformat | commfree | visible | outputfilters | useonairguide | mplexid | serviceid | atscsrcid |
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+
|   2802 | 802     | 573000000 |        2 | WGBHDT   | WGBHDT (WGBH-DT) | none |     NULL |              | 28055   |           0 |    32768 |      32768 |32768 | 32768 | ATSC     |        1 |       1 |               |             0 |       7 |         1 |         0 |
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+

chanid is a unique value in the table.
channum is obvious.
freqid is the frequency from azap, channels.conf,etc.
sourceid corresponds to the correct entry in the videosourceid table.
callsign & name are correct as far as my channel data source goes.
xmltvid is correct.
mplexid corresponds to the correct entry in dvb_multiplex (see below).
service id is 1 from dvbscan output above.
Everything else is set to defaults.

Here's the mplexid row that the above is associated with:

Code:

mysql> select * from dtv_multiplex where mplexid=7;
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+
| mplexid | sourceid | transportid | networkid | frequency | inversion | symbolrate | fec  | polarity | modulation | bandwidth | lp_code_rate | transmission_mode | guard_interval | visible | constellation | hierarchy | hp_code_rate | sistandard | serviceversion | updatetimestamp     |
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+
|       7 |        2 |        NULL |      NULL | 573000000 | a         |       NULL | auto | NULL     | qam_256    | a         | auto         | a      | auto           |       0 | auto          | auto      | auto         | atsc       |             33 | 2005-05-27 18:28:56 |
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+


As soon as I start up mythbackend I see the following in the console window, and I'm unable to manually tune to channel 802:
Code:

2005-05-29 14:37:19.789 DVB#0 DVB SI Table Parser Started
2005-05-29 14:37:19.790 DVB#0 Using DVB card 0, with frontend pcHDTV HD3000 HDTV.
2005-05-29 14:37:20.056 DVB#0 DVB signal ef9c | snr fd13 | ber    0 | unc    0
2005-05-29 14:37:20.056 DVB#0 Status: LOCK.
2005-05-29 14:37:20.056 DVB#0 Multiplex Locked
2005-05-29 14:37:21.330 DVB#0 Successfully tuned to channel 802.
2005-05-29 14:37:21.330 DVB#0 ERROR - Channel #802 is off air.


So myth still seems to be having trouble tuning to this channel. Any idea what I might be missing or doing wrong here?

Thanks,

-Bruce
View user's profile Send private message
Re: Unable to tune QAM channels
PostPosted: Sun May 29, 2005 1:48 pm Reply with quote
mmorris1
Guest
 




brucep wrote:
mmorris1 wrote:

I had the same problem.. MythTV scan fails to find any channels, although you know they are there.. I manually configured the mythconverg database to match the info found in ~/.azap/channnels.conf..
see previous link Posted: Thu May 26, 2005 7:21 am in another forum for futher details
http://www.pchdtv.com/forum/viewtopic.php?t=794


Matthew,

I've tried following the instructions in your other post but I'm not having a whole lot of luck. Here's whatI've tied to tune channel 802, which is WGBH-DT in the Boston area:

In my ~/.azap/channels.conf I have:
WGBH-DT:573000000:QAM_256:2432:2433

If I run azap -r WGBH-DT I can cat /dev/dvb/adapter0/dvr0 and pipe it to an mpg file or straight to mplayer and it works fine. While azap is running I run dvbscan and get the following:
Code:

[mythtv@mythtv-1 ~]$ dvbscan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x1ffb
dumping lists (11 services)
[0002]                   (0x0002) 00: PCR 0x0800          A 0x0801 0x0802 (spa)
[000b]                   (0x000b) 00: PCR 0x0840          A 0x0841 0x0842 (spa)
[0009]                   (0x0009) 00: PCR 0x0880          A 0x0881 0x0882 (spa)
[0008]                   (0x0008) 00: PCR 0x08c0          A 0x08c1 0x08c2 (spa)
[0003]                   (0x0003) 00: PCR 0x0900          A 0x0901 0x0902 (spa)
[0007]                   (0x0007) 00: PCR 0x0940          A 0x0941 0x0942 (spa)
[0001]                   (0x0001) 00: PCR 0x0980          A 0x0981 0x0982 (spa)
[000a]                   (0x000a) 00: PCR 0x09c0          A 0x09c1 0x09c2 (spa)
[0004]                   (0x0004) 00: PCR 0x0a00          A 0x0a01 0x0a02 (spa)
[000c]                   (0x000c) 00: PCR 0x0a40          A 0x0a41 0x0a42 (spa)
[0006]                   (0x0006) 00: PCR 0x0a80          A 0x0a81
Done.

Now this may be where I'm getting mixed up, but given that the PID's I have for WGBH-DT are 0x0980 and 0x0981 I think that the service ID I need to use in myth is 1 (since the lefthand column that corresponds to these PID's is [0001]). Is this correct?

So here's the entry I have in the database for this channel:
Code:

select * from channel where channum=802;
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+
| chanid | channum | freqid    | sourceid | callsign | name             | icon | finetune | videofilters | xmltvid | recpriority | contrast | brightness | colour | hue   | tvformat | commfree | visible | outputfilters | useonairguide | mplexid | serviceid | atscsrcid |
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+
|   2802 | 802     | 573000000 |        2 | WGBHDT   | WGBHDT (WGBH-DT) | none |     NULL |              | 28055   |           0 |    32768 |      32768 |32768 | 32768 | ATSC     |        1 |       1 |               |             0 |       7 |         1 |         0 |
+--------+---------+-----------+----------+----------+------------------+------+----------+--------------+---------+-------------+----------+------------+--------+-------+----------+----------+---------+---------------+---------------+---------+-----------+-----------+

chanid is a unique value in the table.
channum is obvious.
freqid is the frequency from azap, channels.conf,etc.
sourceid corresponds to the correct entry in the videosourceid table.
callsign & name are correct as far as my channel data source goes.
xmltvid is correct.
mplexid corresponds to the correct entry in dvb_multiplex (see below).
service id is 1 from dvbscan output above.
Everything else is set to defaults.

Here's the mplexid row that the above is associated with:

Code:

mysql> select * from dtv_multiplex where mplexid=7;
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+
| mplexid | sourceid | transportid | networkid | frequency | inversion | symbolrate | fec  | polarity | modulation | bandwidth | lp_code_rate | transmission_mode | guard_interval | visible | constellation | hierarchy | hp_code_rate | sistandard | serviceversion | updatetimestamp     |
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+
|       7 |        2 |        NULL |      NULL | 573000000 | a         |       NULL | auto | NULL     | qam_256    | a         | auto         | a      | auto           |       0 | auto          | auto      | auto         | atsc       |             33 | 2005-05-27 18:28:56 |
+---------+----------+-------------+-----------+-----------+-----------+------------+------+----------+------------+-----------+--------------+-------------------+----------------+---------+---------------+-----------+--------------+------------+----------------+---------------------+


As soon as I start up mythbackend I see the following in the console window, and I'm unable to manually tune to channel 802:
Code:

2005-05-29 14:37:19.789 DVB#0 DVB SI Table Parser Started
2005-05-29 14:37:19.790 DVB#0 Using DVB card 0, with frontend pcHDTV HD3000 HDTV.
2005-05-29 14:37:20.056 DVB#0 DVB signal ef9c | snr fd13 | ber    0 | unc    0
2005-05-29 14:37:20.056 DVB#0 Status: LOCK.
2005-05-29 14:37:20.056 DVB#0 Multiplex Locked
2005-05-29 14:37:21.330 DVB#0 Successfully tuned to channel 802.
2005-05-29 14:37:21.330 DVB#0 ERROR - Channel #802 is off air.


So myth still seems to be having trouble tuning to this channel. Any idea what I might be missing or doing wrong here?

Thanks,

-Bruce


Hello Bruce

What about the sourceid.. I am using coax input on my HD3000 and this corresponds to sourceid =1 in the dtv_multiplex table.

Regards Matt
Re: Unable to tune QAM channels
PostPosted: Sun May 29, 2005 7:11 pm Reply with quote
Guest
 




mmorris1 wrote:
Hello Bruce

What about the sourceid.. I am using coax input on my HD3000 and this corresponds to sourceid =1 in the dtv_multiplex table.

Regards Matt

Matt,

I don't know how my dtv_multiplex table was initially created but all the sourceid values were 2. I'm using the coax input as well, so I tried changing them all to 1 then restarted mythbackend. But I still see the same "DVB#0 ERROR - Channel #802 is off air" error on startup and still can't tune any of the HD3000's channels. Any other thoughts?

-Bruce
Re: Unable to tune QAM channels
PostPosted: Sun May 29, 2005 7:16 pm Reply with quote
Guest
 




Anonymous wrote:
mmorris1 wrote:
Hello Bruce

What about the sourceid.. I am using coax input on my HD3000 and this corresponds to sourceid =1 in the dtv_multiplex table.

Regards Matt

Matt,

I don't know how my dtv_multiplex table was initially created but all the sourceid values were 2. I'm using the coax input as well, so I tried changing them all to 1 then restarted mythbackend. But I still see the same "DVB#0 ERROR - Channel #802 is off air" error on startup and still can't tune any of the HD3000's channels. Any other thoughts?

-Bruce


Hi Bruce

Pretty mysterious..
What do you have in the Tables capturecard and cardinput ?

MM
Re: Unable to tune QAM channels
PostPosted: Sun May 29, 2005 8:54 pm Reply with quote
mmorris1
Guest
 




Anonymous wrote:
Anonymous wrote:
mmorris1 wrote:
Hello Bruce

What about the sourceid.. I am using coax input on my HD3000 and this corresponds to sourceid =1 in the dtv_multiplex table.

Regards Matt

Matt,

I don't know how my dtv_multiplex table was initially created but all the sourceid values were 2. I'm using the coax input as well, so I tried changing them all to 1 then restarted mythbackend. But I still see the same "DVB#0 ERROR - Channel #802 is off air" error on startup and still can't tune any of the HD3000's channels. Any other thoughts?

-Bruce


Hi Bruce

Pretty mysterious..
What do you have in the Tables capturecard and cardinput ?

MM


Hello Bruce

One more thing.. to get more info from mythtv.. try starting mythbackend with very verbose options.
Code:
 mythbackend -d -l /var/tmp/mythbackend.log -v all
Re: Unable to tune QAM channels
PostPosted: Mon May 30, 2005 1:25 pm Reply with quote
brucep
 
Joined: 28 Dec 2004
Posts: 12




Well I decided to delete all my configuration settings & start over again just to make sure I had everything clean to begin with. I've got 2 HD-3000 cards in this system. I decided to hook one up to an antenna just to see if I could get it to work properly in mythtv. So what I did was configure just the one with the antenna first, created a channel linup, and immediately had it scan for channels (without running mythfilldatabase first). This worked well enough for me to be able to tune in a few over-the--air channels with myth.

I then did a scan for channels on the HD-3000 hooked up to my cable and it added more entries to the dtv_multiplex table. I don't know if it's important or not but the transportid for all these entries were NULL. With the entries for the over-the-air channels the transportid's have 4-digit numbers. So that may be part of my problem. Do I need transportid values for QAM?

To add channels on the cable connection I made sure I had the proper entries in my channels.conf file:

WCVB:573000000:QAM_256:2304:2305
WBZ:603000000:QAM_256:2048:2049

While running azap to tune these channels I ran dvbscan, and here's the output I got:

Code:

[mythtv@mythtv-1 ~]$ azap -r WBZ
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 603000000 Hz
video pid 0x0800, audio pid 0x0801
status 1f | signal fdf2 | snr fda9 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal f8d4 | snr fdcd | ber 00000000 | unc 00000000 | FE_HAS_LOCK

[mythtv@mythtv-1 ~]$ dvbscan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x1ffb
dumping lists (2 services)
[0002]                   (0x0002) 00: PCR == V   V 0x0800 A 0x0801
[0001]                   (0x0001) 00: PCR == V   V 0x0840 A 0x0841 (eng)
Done.

[mythtv@mythtv-1 ~]$ azap -r WCVB-5-16x9
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 573000000 Hz
video pid 0x0900, audio pid 0x0901
status 1f | signal 0394 | snr f7d3 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal f8d4 | snr fd47 | ber 00000000 | unc 00000000 | FE_HAS_LOCK

[mythtv@mythtv-1 ~]$ dvbscan -c
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
WARNING: filter timeout pid 0x1ffb
dumping lists (11 services)
[0002]                   (0x0002) 00: PCR 0x0800          A 0x0801 0x0802 (spa)
[000b]                   (0x000b) 00: PCR 0x0840          A 0x0841 0x0842 (spa)
[0009]                   (0x0009) 00: PCR 0x0880          A 0x0881 0x0882 (spa)
[0008]                   (0x0008) 00: PCR 0x08c0          A 0x08c1 0x08c2 (spa)
[0003]                   (0x0003) 00: PCR 0x0900          A 0x0901 0x0902 (spa)
[0007]                   (0x0007) 00: PCR 0x0940          A 0x0941 0x0942 (spa)
[0001]                   (0x0001) 00: PCR 0x0980          A 0x0981 0x0982 (spa)
[000a]                   (0x000a) 00: PCR 0x09c0          A 0x09c1 0x09c2 (spa)
[0004]                   (0x0004) 00: PCR 0x0a00          A 0x0a01 0x0a02 (spa)
[000c]                   (0x000c) 00: PCR 0x0a40          A 0x0a41 0x0a42 (spa)
[0006]                   (0x0006) 00: PCR 0x0a80          A 0x0a81
Done.


Given the above data I tried to add channels 804 & 805 manually to the channel table. Here are all the relevant pieces of data from that:

Code:
mysql> select cardinputid,cardid,sourceid,inputname,startchan,lnb_lof_switch,lnb_lof_hi,lnb_lof_lo from cardinput;
+-------------+--------+----------+-----------+-----------+----------------+------------+------------+
| cardinputid | cardid | sourceid | inputname | startchan | lnb_lof_switch | lnb_lof_hi | lnb_lof_lo |
+-------------+--------+----------+-----------+-----------+----------------+------------+------------+
|           1 |      1 |        1 | DVBInput  | 251       |       11700000 |   10600000 |    9750000 |
|           2 |      2 |        2 | DVBInput  | 805       |       11700000 |   10600000 |    9750000 |
+-------------+--------+----------+-----------+-----------+----------------+------------+------------+

mysql> select cardid,videodevice,cardtype,defaultinput from capturecard;
+--------+-------------+----------+--------------+
| cardid | videodevice | cardtype | defaultinput |
+--------+-------------+----------+--------------+
|      1 | 1           | DVB      | DVBInput     |
|      2 | 0           | DVB      | DVBInput     |
+--------+-------------+----------+--------------+

mysql> select chanid,channum,freqid,sourceid,callsign,tvformat,mplexid,serviceid,atscsrcid from channel where sourceid=2;
+--------+---------+--------+----------+----------+----------+---------+-----------+-----------+
| chanid | channum | freqid | sourceid | callsign | tvformat | mplexid | serviceid | atscsrcid |
+--------+---------+--------+----------+----------+----------+---------+-----------+-----------+
|   2000 | 804     |        |        2 | WBZDT    | Default  |      24 |         1 |         0 |
|   2001 | 805     |        |        2 | WCVB     | Default  |      19 |         3 |         0 |
+--------+---------+--------+----------+----------+----------+---------+-----------+-----------+

mysql> select mplexid,sourceid,transportid,networkid,frequency from dtv_multiplex where mplexid=19 or mplexid=24;
+---------+----------+-------------+-----------+-----------+
| mplexid | sourceid | transportid | networkid | frequency |
+---------+----------+-------------+-----------+-----------+
|      19 |        2 |        NULL |      NULL | 573000000 |
|      24 |        2 |        NULL |      NULL | 603000000 |
+---------+----------+-------------+-----------+-----------+


As far as I can tell it looks like I have everything set properly with the possible exception of the null transportid values in dtv_multiplex...

-Bruce
View user's profile Send private message
Unable to tune QAM channels
  pcHDTV Forum Index -> mythTV wiith the HD-2000 card
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin