Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> xine-hd -> Package xft was not found in the pkg-config search path
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
Package xft was not found in the pkg-config search path
PostPosted: Thu Dec 30, 2004 5:18 pm Reply with quote
wildrice
 
Joined: 28 Dec 2004
Posts: 10




I finally have xine-hd-lib installed. Now I am working on the ui, but when I run ./configure, I get:

Code:
[root@mythtv xine-hd-ui-0.99.2]# ./configure > out-configure
Package xft was not found in the pkg-config search path.
Perhaps you should add the directory containing `xft.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xft' found
Package xft was not found in the pkg-config search path.
Perhaps you should add the directory containing `xft.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xft' found
configure: error: *** libpng is needed (PNG library not found) - try to use --with-png-prefix option ***


However, apt-get tells me:

Code:
[root@mythtv xine-hd-ui-0.99.2]# apt-get install Xft
Reading Package Lists... Done
Building Dependency Tree... Done
Package Xft has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
However the following packages replace it:
  xorg-x11-libs
E: Package Xft has no installation candidate


and

Code:
[root@mythtv xine-hd-ui-0.99.2]# apt-get install libpng
Reading Package Lists... Done
Building Dependency Tree... Done
libpng is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.


In newbie terms, what am I missing? I am installing on a x86_64 FC3 with all the i386 stuff removed. I am not sure what to do with the --with-png-prefix, but adding that string to the ./configure did not help. -Chuck-
View user's profile Send private message
PostPosted: Thu Dec 30, 2004 7:57 pm Reply with quote
wildrice
 
Joined: 28 Dec 2004
Posts: 10




Found the problem. I had to:

Code:
apt-get install xorg-x11-devel
apt-get install Xft-devel
apt-get install aalib-devel


I am still geting come errors on CURL-LIB and caca, but they just disable and the ./configure continues to completion. -Chuck-
View user's profile Send private message
Re: Package xft was not found in the pkg-config search path
PostPosted: Wed Sep 14, 2005 1:08 pm Reply with quote
Guest
 




[quote="wildrice"]I finally have xine-hd-lib installed. Now I am working on the ui, but when I run ./configure, I get:

[code][root@mythtv xine-hd-ui-0.99.2]# ./configure > out-configure
Package xft was not found in the pkg-config search path.
Perhaps you should add the directory containing `xft.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xft' found
Package xft was not found in the pkg-config search path.
Perhaps you should add the directory containing `xft.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xft' found
configure: error: *** libpng is needed (PNG library not found) - try to use --with-png-prefix option ***
[/code]

However, apt-get tells me:

[code][root@mythtv xine-hd-ui-0.99.2]# apt-get install Xft
Reading Package Lists... Done
Building Dependency Tree... Done
Package Xft has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
However the following packages replace it:
xorg-x11-libs
E: Package Xft has no installation candidate
[/code]

and

[code][root@mythtv xine-hd-ui-0.99.2]# apt-get install libpng
Reading Package Lists... Done
Building Dependency Tree... Done
libpng is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.[/code]

In newbie terms, what am I missing? I am installing on a x86_64 FC3 with all the i386 stuff removed. I am not sure what to do with the --with-png-prefix, but adding that string to the ./configure did not help. -Chuck-[/quote]
Package xft was not found in the pkg-config search path
  pcHDTV Forum Index -> xine-hd
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin