Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> General pcHDTV topics -> WB's Smallville and Angel have no audio...
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
WB's Smallville and Angel have no audio...
PostPosted: Wed May 19, 2004 11:57 pm Reply with quote
Gendal
Guest
 




Running Ulmo's 4a drivers and they work great except for the WB KTLA station, but only for their true hdtv shows like smallville and angel. I get no audio with either mythtv, mplayer, xine, vlc on linux or vlc or media player classic on winxp. VLC shows it to have a spanish ac3 track but it's dead silent. I can demux it's ac3 track on PID 0x14 but it's silent too. TSReaderLite shows it as having vid at PID 0x11 and audio at 0x11.

Is this a problem with the drivers? I thought the drivers would just hand over the broadcast transport stream, but I can't get any audio out of it. Video is there and looks great, but that's it.

Any hints on where to look? If at all possible I would like to salvage the half a dozen recordings I have made, but if that's not possible I would at least like to figure out a way to record the WB's hdtv content. Precious little out there as it is =)
PostPosted: Wed May 19, 2004 11:58 pm Reply with quote
Guest
 




Just wanted to add I actually get audio if it starts with a commercial till the show starts then no audio even if a commercial comes on later. Just plain wierd...
Re: WB's Smallville and Angel have no audio...
PostPosted: Fri May 21, 2004 2:01 am Reply with quote
pdicamillo
 
Joined: 09 Mar 2004
Posts: 68
Location: Needham, MA




You're correct about the drivers. They provide the complete transport stream to the tuner devices. If they were corrupting the stream in some way, it's very unlikely only the audio would be affected.

What does dtvstream list for the streams if you use "dtvstream -i input-file -q" (where input-file is one of your recordings)? I get something like this for my WB station:

Code:

Stream contains 3 valid program(s).
    Program 2: 56-1 WLVI-D1:
        Video (MPEG-2), language = eng
        Audio (Dolby AC-3), language = eng
        Audio (Dolby AC-3), language = spa
    Program 3: 56-2 WLVI-D2:
        Video (MPEG-2), language = eng
        Audio (Dolby AC-3), language = spa
    Program 4:
        Video (MPEG-2)
        Audio (Dolby AC-3)
        Audio (Dolby AC-3)


and only program 2 has working audio. If you have more than one program, you might want to see if it makes any difference to use dtvstream to make a file which contains only the first program.
View user's profile Send private message AIM Address
PostPosted: Fri May 21, 2004 11:17 am Reply with quote
Gendal
Guest
 




Summary after scanning first 20000 packets:
3 MBytes processed @ 6000 Mb/s
79 pes_pkts processed
0 atsc_pkts, w/ distribution:
sst=0/0, mgt=0/0, vct=0/0, rrt=0/0,dcct=0/0, dccsct=0/0
Dropped pkts (Continuity Counter Errors) = 0
Active PIDs in this stream
PID=0x0, ctrl_type=PAT, pkt_cnt=29
PID=0x10, ctrl_type=PMT, pkt_cnt=29
PID=0x11, ctrl_type=VIDEO, pkt_cnt=19327
PID=0x14, ctrl_type=AUDIO_AC3, pkt_cnt=554
Stream contains 1 total program(s).
Stream contains 1 valid program(s).
Using program 1:
Video (MPEG-2)
Audio (Dolby AC-3)


The above is what dtvstream pumps out for me with -q -v. TSReaderLite says the same thing. As far as I can tell it just has the one program. Other channels like ABC have up to 3 (the show, news, and weather) but the programs I use, ie vlc, can switch between the different audio and video tracks with out a problem.

No idea why I can't play the audio still unless something is being corrupted either by the station broadcasting or something on my end.
WB's Smallville and Angel have no audio...
  pcHDTV Forum Index -> General pcHDTV topics
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin