Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> Gentoo 2.6.17-gentoo-r5, ivtv-0.7.0, pchdtv 5500
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
Gentoo 2.6.17-gentoo-r5, ivtv-0.7.0, pchdtv 5500
PostPosted: Fri Aug 25, 2006 5:15 pm Reply with quote
shepmaster
 
Joined: 25 Aug 2006
Posts: 8




Hey all, I'm trying to get the above 3 items to play nicely together. The kernel version of the dvb drivers doesn't recognize the 5500, so I downloaded the version from here. However, I notice that the drivers from linuxtv.org are supposedly newer (especially the Hg sources). Which should I use?

Thanks!
View user's profile Send private message
PostPosted: Fri Aug 25, 2006 9:20 pm Reply with quote
MasterC
 
Joined: 28 Jun 2005
Posts: 23




I just set this up today. Not sure where your problem is, but here was the order I used:

Installed kernel, configured.

Installed IVTV

Installed HD5500 Drivers (downloaded from the downloads section of pchdtv.com)

And they are all playing nice together.

-Chad
View user's profile Send private message
PostPosted: Wed Sep 13, 2006 5:33 pm Reply with quote
yesare
 
Joined: 08 Sep 2006
Posts: 4




MasterC, can you post your configuration and steps on how you got the pvr350 and pcHDTV work together? I am trying to do the same and I haven't had any luck so far. pcHDTV loads but I can never get the ivtv to load.

When I run ivtv-detect I get this.

driver: cx8800-0.0.5
card: pcHDTV HD5500 HDTV, bus info PCI:0000:02:07.0
/dev/v4l/video0: YUV encoding (links: /dev/video0)
/dev/v4l/vbi0: VBI encoding (links: /dev/vbi0)

Thanks
View user's profile Send private message
PostPosted: Sat Sep 16, 2006 6:40 am Reply with quote
shepmaster
 
Joined: 25 Aug 2006
Posts: 8




I haven't got them working 100%, but I can record from one or both cards occasionally.

I am using ivtv 0.7.0 and the 5500 drivers from the website. My kernel version is 2.6.17-gentoo-r5.

Do an lsmod. Is cx88-blackbird in your list? if so, delete (or move away) that module from your modules folder. Then try unloading all v4l2 drivers, and modprobe ivtv and cx88-dvb.

I followed the respective installation instructions for each set of drivers. The only thing I would suggest doing special is to switch the order that you do things. Try installing the kernel modules, then the 5500 drivers, then ivtv. Then try to modprobe ivtv before cx88. If no luck, try the four combinations of order (kernel always first):

install kernel->ivtv->5500 & modprobe ivtv->5500
install kernel->5500->ivtv & modprobe ivtv->5500
install kernel->ivtv->5500 & modprobe 5500->ivtv
install kernel->5500->ivtv & modprobe 5500->ivtv

Sounds tedious, yes? I seem to remember someone suggesting something similar somewhere on the net. Very Happy
View user's profile Send private message
Gentoo 2.6.17-gentoo-r5, ivtv-0.7.0, pchdtv 5500
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin