Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> 5500/soundcard conflict?
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
5500/soundcard conflict?
PostPosted: Mon Nov 06, 2006 9:51 am Reply with quote
old_skul
 
Joined: 06 Nov 2006
Posts: 19




I'm using Auto-install of Knoppmyth R5D1 on a box that I had configured R5D1 on before. Everything was working. Then I put in a new sound card, and my sound stopped working (and I didn't know enough to use alsa_init).

If I try to install with my tuner card (a pchdtv 55000) installed along with my sound card (an Audigy SE), the install gets as far as autodetecting hardware, and then to updating modules, and then it says "Setting default volumes..." and locks.

That message is incidentally part of alsa_init or possibly also_autoconfig.

If I remove my tuner card, the install proceeds normally. I am able to autoinstall, get my tuner card drivers installed, run alsamixer, install lame and lib2dvdcss, and I can watch DVDs/play MP3s and the sound is fine.

Then I install the tuner card. On boot, everything looks fine, and myth starts. Now there's no sound. If I run alsa_init, alsa_autoconfig, amixer or alsamixer, I get a kernel dump and the system has to be restarted.

What's wrong? What can I try?

_________________
old_skul
View user's profile Send private message
PostPosted: Mon Nov 06, 2006 11:26 am Reply with quote
nybbler
 
Joined: 06 Jul 2006
Posts: 125




Possibly the tuner card is getting the first device index, which doesn't work out so well.

Add a file in /etc/modprobe.d (I call mine "no-cx88-first") containing the following line:

options cx88_alsa index=-2

and see if that helps.
View user's profile Send private message
PostPosted: Tue Nov 07, 2006 1:38 pm Reply with quote
old_skul
 
Joined: 06 Nov 2006
Posts: 19




Nope. Same behavior. Is there a log or dmesg output I could post that would help?

_________________
old_skul
View user's profile Send private message
5500/soundcard conflict?
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin