Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> HD-2000/3000 drivers -> HD3000 Digital Static / DMA Problem?
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
HD3000 Digital Static / DMA Problem?
PostPosted: Thu Dec 21, 2006 1:02 pm Reply with quote
adagi
 
Joined: 21 Dec 2006
Posts: 1




Hi - I've been trying to track down this problem for awhile now, and am hoping someone here can help. I've read about similar problems in the boards but they were resolved with replacing memory or power-supply - I tried both to no avail.

==Symptoms==
1. I get digital static and audio errors when viewing a QAM channel
2. This doesn't happen with over the air channels
3. The amount of static drops (but there is always a little) when: (a) I exit X and just capture the data - I am using the latest nvidia drivers - but there is a little bit, (b) drop the speed of my memory from 400Mhz to 266Mhz, (c) remove one of the memory modules and run the system in single-channel rather than dual channel - I've tested with brand new memory chips so that isn't a problem, (d) disable pre-emption in the kernel, (e) drop the kernel timer to 100Hz from 1000Hz.
4. Static appears to be directly correlated to loss of channel lock (when I do an azap -r, it shows 98-100% signal 80% of the time). This is cable, so it can't be bad signal (right?)
5. I've replaced memory and the power-supply, but no difference

==System description==
Kernel 2.6.19-gentoo-r2, AMD64, Asus A8N SLI deluxe, 1Gb (2x512Mb, 400Mhz memory, dual channel 1280bit), GeForce 6200 (nvidia drivers, 9631)

==LSPCI output==
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6200] (rev a2)
05:07.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
05:07.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)

==dmesg output=
cx2388x dvb driver version 0.0.6 loaded
CORE cx88[0]: subsystem: 7063:3000, board: pcHDTV HD3000 HDTV [card=22,autodetected]
TV tuner 60 at 0x1fe, Radio tuner -1 at 0x1fe
cx2388x v4l2 driver version 0.0.6 loaded
ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
ACPI: PCI Interrupt 0000:05:07.2[A] -> Link [APC2] -> GSI 17 (level, low) -> IRQ 17
cx88[0]/2: found at 0000:05:07.2, rev: 5, irq: 17, latency: 32, mmio: 0xd1000000
cx88[0]/2: cx2388x based dvb card
usb 2-2: new low speed USB device using ohci_hcd and address 2
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 0 (Oren OR51132 VSB/QAM Frontend)...
ACPI: PCI Interrupt 0000:05:07.0[A] -> Link [APC2] -> GSI 17 (level, low) -> IRQ 17
cx88[0]/0: found at 0000:05:07.0, rev: 5, irq: 17, latency: 32, mmio: 0xd0000000
tuner 2-0043: chip found @ 0x86 (cx88[0])
tda9887 2-0043: tda988[5/6/7] found @ 0x43 (tuner)
tuner 2-0061: chip found @ 0xc2 (cx88[0])
tuner 2-0061: type set to 60 (Thomson DTT 761X (ATSC/NTSC))
tuner 2-0061: type set to 60 (Thomson DTT 761X (ATSC/NTSC))
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx88[0]/0: registered device radio0


I think that this may be a DMA problem with how the card transfers data to main memory - but given the complexity of the drivers I haven't been able to debug it fully. Does anyone have any ideas on how to fix this or where to start?
View user's profile Send private message
HD3000 Digital Static / DMA Problem?
  pcHDTV Forum Index -> HD-2000/3000 drivers
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin