Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> General pcHDTV topics -> Loss of /dev/dvb after updating ivtv to 1:0.4.3-106
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
Loss of /dev/dvb after updating ivtv to 1:0.4.3-106
PostPosted: Tue Mar 21, 2006 9:52 am Reply with quote
desertgeek
 
Joined: 20 Mar 2006
Posts: 1




I have an AMD64 3200+ on a Gigabyte GA-K8NSC-939 MB (nForce3 250GB) with 2 GB dual channal DDR. I have an HD-3000 and a PVR-350 installed. I am running Fedora Core 4 with the latest kernel.

I had both the HD-3000 (/dev/dvb/adapter0) and the PVR-350 (/dev/video0) working with MythTV. I performed yum update and it installed the latest ivtv. Since then, I have lost /dev/dvb and whether I use v4l or bttv, the HD-3000 does nothing. I tried scanning for channels and nothing is received, etc. I checked dmesg and got the infamous teevee_prom errors others have been experiencing. Since that is to use ivtv/bttv for capture, I'm not too worried about it because I want to use DVB. In one of the posts I read, someone uninstalled ivtv and the HD-3000 card started working. They reinstalled ivtv and both cards worked. I tried uninstalling ivtv but I still did not get /dev/dvb back. After searching other posts I tried 'modprobe dvb' and lo and behold, it came back!

Now, I'm trying to find out where to get dvb to load again during boot, but I'm not sure exactly where. Does anyone know where/how to get it to start loading again?
View user's profile Send private message
PostPosted: Tue Mar 21, 2006 4:30 pm Reply with quote
waterhead
 
Joined: 24 Apr 2005
Posts: 299




I made notes when I did my install. In order to get my dvb module loaded at boot, this is what I had to do:

In /lib/modules/2.6.14-1.1637_FC4/modules.pcimap move cx88-dvb so that it is above cx8800 and cx8800 blackbird. Your kernel version may be different.

_________________
Mythbuntu 8.04
Intel D875PBZ main board
Pentium4 3.06Ghz
1024GB RAM
nVidia 6600GT
pcHDTV HD-3000
Air2PC PCI
MythTV 0.21
View user's profile Send private message
Loss of /dev/dvb after updating ivtv to 1:0.4.3-106
  pcHDTV Forum Index -> General pcHDTV topics
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin