Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Driver Issues -> v4l-dvb make error's - kernel-source-2.6.15-chw-2
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
v4l-dvb make error's - kernel-source-2.6.15-chw-2
PostPosted: Fri Aug 25, 2006 1:25 pm Reply with quote
tscholl
 
Joined: 25 Aug 2006
Posts: 5




This is a Knoppmyth R5C7 install with the latest 19 fixes installed, with three capture card, HD-3000, PVR350, PVR150. The HD-5500 will make the 4th capture card.

When I try to install the Drivers for the HD-5500 card how ever get the following errors when I try to run the make.

root@mythtv:/usr/src/v4l-dvb# make
make -C /usr/src/v4l-dvb/v4l
make[1]: Entering directory `/usr/src/v4l-dvb/v4l'
echo "No version yet."
No version yet.
uname -r|perl -ne 'if (/^([0-9]*)\.([0-9])*\.([0-9]*)(.*)$/) { printf ("VERSION=%s\nPATCHLEVEL:=%s\nSUBLEVEL:=%s\nKERNELRELEASE:=%s.%s.%s%s\n",$1,$2,$3,$1,$2,$3,$4); };' > ./.version
make[1]: Leaving directory `/usr/src/v4l-dvb/v4l'
make[1]: Entering directory `/usr/src/v4l-dvb/v4l'
scripts/make_makefile.pl
creating symbolic links...
make -C /lib/modules/2.6.15-chw-2/build SUBDIRS=/usr/src/v4l-dvb/v4l modules
make[2]: Entering directory `/usr/src/kernel-source-2.6.15-chw-2'
CC [M] /usr/src/v4l-dvb/v4l/flexcop-pci.o
In file included from /usr/src/v4l-dvb/v4l/flexcop-common.h:20,
from /usr/src/v4l-dvb/v4l/flexcop-pci.c:10:
/usr/src/v4l-dvb/v4l/dmxdev.h:79: error: field `filter_mutex' has incomplete type
/usr/src/v4l-dvb/v4l/dmxdev.h:103: error: field `dmx_mutex' has incomplete type
In file included from /usr/src/v4l-dvb/v4l/flexcop-common.h:21,
from /usr/src/v4l-dvb/v4l/flexcop-pci.c:10:
/usr/src/v4l-dvb/v4l/dvb_demux.h:131: error: field `demux_mutex' has incomplete type
In file included from /usr/src/v4l-dvb/v4l/flexcop-pci.c:10:
/usr/src/v4l-dvb/v4l/flexcop-common.h:80: error: field `i2c_mutex' has incomplete type
make[3]: *** [/usr/src/v4l-dvb/v4l/flexcop-pci.o] Error 1
make[2]: *** [_module_/usr/src/v4l-dvb/v4l] Error 2
make[2]: Leaving directory `/usr/src/kernel-source-2.6.15-chw-2'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/usr/src/v4l-dvb/v4l'
make: *** [all] Error 2
root@mythtv:/usr/src/v4l-dvb#

Has anyone seen this or have a solution for this problem?

Thanks
View user's profile Send private message
PostPosted: Fri Aug 25, 2006 2:05 pm Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




Read my post here
View user's profile Send private message
PostPosted: Sat Aug 26, 2006 8:00 am Reply with quote
tscholl
 
Joined: 25 Aug 2006
Posts: 5




xyzzy

Tried running the "hg diff" but got a command not found.

I did edit the v4l/compat.h. At the last KERNEL_VERSION at the end of the file, change the number from 2,6,14 to 2,6,15.

Then ran the make and it compiled without errors!! Thanks!!
View user's profile Send private message
PostPosted: Sun Aug 27, 2006 10:47 am Reply with quote
tscholl
 
Joined: 25 Aug 2006
Posts: 5




Looks like that fixed the install problem but it broke my ivtv drivers v.0.4.6
so I got nothing on my 2 PVR card. I got a:
Aug 26 12:32:29 mythtv kernel: tuner 2-0061: tuner type not set
error on both PVR's

I tried reinstalled the ivtv drivers, but that didn't help, and finally decided to try the back level 0.4.4 drivers. After that both tuner types are set initilized. but there is no sound from the PVR350, the PVR150 is ok. Looks like a probelm with

Before the drivers were install:
Aug 26 10:14:39 mythtv kernel: msp3400 2-0040: chip=MSP4448G-A2 +nicam +simple +simpler +radio mode=simpler
Aug 26 10:14:39 mythtv kernel: msp3400 2-0040: msp34xxg daemon started

After the drivers installed and reinstalled ivtv 0.4.4
Aug 26 20:05:14 mythtv kernel: msp3400 3-0040: MSP4448G-A2 found @ 0x80 (ivtv i2c driver #0)
Aug 26 20:05:14 mythtv kernel: msp3400 3-0040: MSP4448G-A2 supports radio, mode is autodetect and autoselect
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=MSP4448G-A2, addr=40]

the full ivtv listing are listed below:

Aug 26 10:14:38 mythtv kernel: ivtv: ==================== START INIT IVTV ====================
Aug 26 10:14:38 mythtv kernel: ivtv: version 0.4.6 (tagged release) loading
Aug 26 10:14:38 mythtv kernel: ivtv: Linux version: 2.6.15-chw-2 SMP preempt 586 gcc-3.3
Aug 26 10:14:38 mythtv kernel: ivtv: In case of problems please include the debug info between
Aug 26 10:14:38 mythtv kernel: ivtv: the START INIT IVTV and END INIT IVTV lines, along with
Aug 26 10:14:38 mythtv kernel: ivtv: any module options, when mailing the ivtv-users mailinglist.
Aug 26 10:14:38 mythtv kernel: ivtv0: Autodetected WinTV PVR 350 card (cx23415 based)
Aug 26 10:14:38 mythtv kernel: ACPI: PCI Interrupt 0000:02: 0b.0[A] -> GSI 23 (level, low) -> IRQ 23
Aug 26 10:14:38 mythtv kernel: tveeprom: ivtv version
Aug 26 10:14:38 mythtv kernel: tveeprom: Hauppauge: model = 48132, rev = K268, serial# = 8375830
Aug 26 10:14:38 mythtv kernel: tveeprom: tuner = LG TAPE H001F MK3 (idx = 68, type = 47)
Aug 26 10:14:38 mythtv kernel: tveeprom: tuner fmt = NTSC(M) (eeprom = 0x08, v4l2 = 0x00001000)
Aug 26 10:14:38 mythtv kernel: tveeprom: audio processor = MSP4448 (type = 1b)
Aug 26 10:14:38 mythtv kernel: tveeprom: decoder processor = SAA7115 (type = 13)
Aug 26 10:14:38 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=tveeprom, addr=50]
Aug 26 10:14:38 mythtv kernel: tuner (ivtv): chip found at addr 0xc2 i2c-bus ivtv i2c driver #0
Aug 26 10:14:38 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=(tuner unset), addr=61]
Aug 26 10:14:39 mythtv kernel: saa7115 2-0021: saa7115 found @ 0x42 (ivtv i2c driver #0)
Aug 26 10:14:39 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=saa7115, addr=21]
Aug 26 10:14:39 mythtv kernel: saa7127 2-0044: ivtv driver
Aug 26 10:14:39 mythtv kernel: saa7127 2-0044: saa7129 found @ 0x88 (ivtv i2c driver #0)
Aug 26 10:14:39 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=saa7127, addr=44]
Aug 26 10:14:39 mythtv kernel: msp3400 2-0040: chip=MSP4448G-A2 +nicam +simple +simpler +radio mode=simpler
Aug 26 10:14:39 mythtv kernel: msp3400 2-0040: msp34xxg daemon started
Aug 26 10:14:39 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=MSP4448G-A2, addr=40]
Aug 26 10:14:39 mythtv kernel: tda9887 2-0043: (ivtv) chip found @ 0x86 (ivtv i2c driver #0)
Aug 26 10:14:39 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=tda9887, addr=43]
Aug 26 10:14:40 mythtv kernel: ivtv0: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
Aug 26 10:14:40 mythtv kernel: ivtv0: loaded v4l-cx2341x-dec.fw firmware (262144 bytes)
Aug 26 10:14:40 mythtv kernel: ivtv0: Encoder revision: 0x02050032
Aug 26 10:14:40 mythtv kernel: ivtv0: Decoder revision: 0x02020023
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: Create encoder radio stream
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA decoder MPEG stream: 16 x 65536 buffers (1024KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA decoder VBI stream: 512 x 2048 buffers (1024KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: Create decoder VOUT stream
Aug 26 10:14:40 mythtv kernel: ivtv0: Allocate DMA decoder YUV stream: 24 x 43200 buffers (1024KB total)
Aug 26 10:14:40 mythtv kernel: ivtv0: loaded v4l-cx2341x-init.mpg firmware (155648 bytes)
Aug 26 10:14:40 mythtv kernel: tuner: type set to 47 (LG NTSC (TAPE series)) by ivtv i2c driver #0
Aug 26 10:14:41 mythtv kernel: ivtv0: Initialized WinTV PVR 350, card #0
Aug 26 10:14:41 mythtv kernel: ivtv: ====================== NEXT CARD ======================
Aug 26 10:14:41 mythtv kernel: ivtv1: Autodetected WinTV PVR 150 card (cx23416 based)
Aug 26 10:14:41 mythtv kernel: ACPI: PCI Interrupt 0000:02: 0d.0[A] -> GSI 21 (level, low) -> IRQ 20
Aug 26 10:14:41 mythtv kernel: tveeprom: ivtv version
Aug 26 10:14:41 mythtv kernel: tveeprom: Hauppauge: model = 26582, rev = F0B2, serial# = 9486064
Aug 26 10:14:41 mythtv kernel: tveeprom: tuner = TCL M2523_5N_E (idx = 112, type = 50)
Aug 26 10:14:41 mythtv kernel: tveeprom: tuner fmt = NTSC(M) (eeprom = 0x08, v4l2 = 0x00001000)
Aug 26 10:14:41 mythtv kernel: tveeprom: audio processor = CX25843 (type = 25)
Aug 26 10:14:41 mythtv kernel: tveeprom: decoder processor = CX25843 (type = 1e)
Aug 26 10:14:41 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=tveeprom, addr=50]
Aug 26 10:14:41 mythtv kernel: tuner (ivtv): chip found at addr 0xc2 i2c-bus ivtv i2c driver #1
Aug 26 10:14:41 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=(tuner unset), addr=61]
Aug 26 10:14:41 mythtv kernel: cx25840 3-0044: ivtv driver
Aug 26 10:14:41 mythtv kernel: cx25840 3-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #1)
Aug 26 10:14:44 mythtv kernel: cx25840 3-0044: loaded v4l-cx25840.fw firmware (16382 bytes)
Aug 26 10:14:44 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=cx25840, addr=44]
Aug 26 10:14:44 mythtv kernel: wm8775 3-001b: chip found @ 0x36 (ivtv i2c driver #1)
Aug 26 10:14:44 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=wm8775, addr=1b]
Aug 26 10:14:45 mythtv kernel: ivtv1: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
Aug 26 10:14:45 mythtv kernel: ivtv1: Encoder revision: 0x02050032
Aug 26 10:14:45 mythtv kernel: ivtv1: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
Aug 26 10:14:45 mythtv kernel: ivtv1: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
Aug 26 10:14:45 mythtv kernel: ivtv1: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
Aug 26 10:14:45 mythtv kernel: ivtv1: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB total)
Aug 26 10:14:45 mythtv kernel: tuner: type set to 50 (TCL 2002N) by ivtv i2c driver #1
Aug 26 10:14:45 mythtv kernel: ivtv1: Initialized WinTV PVR 150, card #1
Aug 26 10:14:45 mythtv kernel: ivtv: ==================== END INIT IVTV ====================
I also have the log when I was running the ivtv 0.4.4 code and it looks the same as the one above.

------------------------------------------------------------

Now here the same portion of the log after the HD-5500 drivers were installed and I reloaded the ivtv 0.4.4

Aug 26 20:05:14 mythtv kernel: ivtv: ==================== START INIT IVTV ====================
Aug 26 20:05:14 mythtv kernel: ivtv: version 0.4.4 (tagged release) loading
Aug 26 20:05:14 mythtv kernel: ivtv: Linux version: 2.6.15-chw-2 SMP preempt 586 gcc-3.3
Aug 26 20:05:14 mythtv kernel: ivtv: In case of problems please include the debug info between
Aug 26 20:05:14 mythtv kernel: ivtv: the START INIT IVTV and END INIT IVTV lines, along with
Aug 26 20:05:14 mythtv kernel: ivtv: any module options, when mailing the ivtv-users mailinglist.
Aug 26 20:05:14 mythtv kernel: ivtv0: Autodetected WinTV PVR 350 card (cx23415 based)
Aug 26 20:05:14 mythtv kernel: ACPI: PCI Interrupt 0000:02:0b.0[A] -> GSI 23 (level, low) -> IRQ 23
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=tveeprom, addr=50]
Aug 26 20:05:14 mythtv kernel: tuner 3-0061: chip found @ 0xc2 (ivtv i2c driver #0)
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=(tuner unset), addr=61]
Aug 26 20:05:14 mythtv kernel: saa7115 3-0021: saa7115 found @ 0x42 (ivtv i2c driver #0)
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=saa7115, addr=21]
Aug 26 20:05:14 mythtv kernel: saa7127 3-0044: saa7129 found @ 0x88 (ivtv i2c driver #0)
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=saa7127, addr=44]
Aug 26 20:05:14 mythtv kernel: msp3400 3-0040: MSP4448G-A2 found @ 0x80 (ivtv i2c driver #0)
Aug 26 20:05:14 mythtv kernel: msp3400 3-0040: MSP4448G-A2 supports radio, mode is autodetect and autoselect
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=MSP4448G-A2, addr=40]
Aug 26 20:05:14 mythtv kernel: tda9887 3-0043: chip found @ 0x86 (ivtv i2c driver #0)
Aug 26 20:05:14 mythtv kernel: ivtv0: i2c attach to card #0 ok [client=tda9887, addr=43]
Aug 26 20:05:14 mythtv kernel: tveeprom 3-0050: Hauppauge model 48132, rev K268, serial# 8375830
Aug 26 20:05:14 mythtv kernel: tveeprom 3-0050: tuner model is LG TAPE H001F MK3 (idx 68, type 47)
Aug 26 20:05:14 mythtv kernel: tveeprom 3-0050: TV standards NTSC(M) (eeprom 0x08)
Aug 26 20:05:14 mythtv kernel: tveeprom 3-0050: audio processor is MSP4448 (idx 27)
Aug 26 20:05:14 mythtv kernel: tveeprom 3-0050: decoder processor is SAA7115 (idx 19)
Aug 26 20:05:14 mythtv kernel: tveeprom 3-0050: has radio, has IR remote
Aug 26 20:05:15 mythtv kernel: ivtv0: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
Aug 26 20:05:15 mythtv kernel: ivtv0: loaded v4l-cx2341x-dec.fw firmware (262144 bytes)
Aug 26 20:05:15 mythtv kernel: ivtv0: Encoder revision: 0x02050032
Aug 26 20:05:15 mythtv kernel: ivtv0: Decoder revision: 0x02020023
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB total)
Aug 26 20:05:15 mythtv kernel: ivtv0: Create encoder radio stream
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA decoder MPEG stream: 16 x 65536 buffers (1024KB total)
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA decoder VBI stream: 512 x 2048 buffers (1024KB total)
Aug 26 20:05:15 mythtv kernel: ivtv0: Create decoder VOUT stream
Aug 26 20:05:15 mythtv kernel: ivtv0: Allocate DMA decoder YUV stream: 24 x 43200 buffers (1024KB total)
Aug 26 20:05:16 mythtv kernel: ivtv0: loaded v4l-cx2341x-init.mpg firmware (155648 bytes)
Aug 26 20:05:16 mythtv kernel: tuner 3-0061: type set to 47 (LG NTSC (TAPE series))
Aug 26 20:05:16 mythtv kernel: ivtv0: Initialized WinTV PVR 350, card #0
Aug 26 20:05:16 mythtv kernel: ivtv: ====================== NEXT CARD ======================
Aug 26 20:05:16 mythtv kernel: ivtv1: Autodetected WinTV PVR 150 card (cx23416 based)
Aug 26 20:05:16 mythtv kernel: ACPI: PCI Interrupt 0000:02:0d.0[A] -> GSI 21 (level, low) -> IRQ 20
Aug 26 20:05:16 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=tveeprom, addr=50]
Aug 26 20:05:16 mythtv kernel: tuner 4-0061: chip found @ 0xc2 (ivtv i2c driver #1)
Aug 26 20:05:16 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=(tuner unset), addr=61]
Aug 26 20:05:16 mythtv kernel: cx25840 4-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #1)
Aug 26 20:05:20 mythtv kernel: cx25840 4-0044: loaded v4l-cx25840.fw firmware (16382 bytes)
Aug 26 20:05:20 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=cx25840, addr=44]
Aug 26 20:05:20 mythtv kernel: wm8775 4-001b: chip found @ 0x36 (ivtv i2c driver #1)
Aug 26 20:05:20 mythtv kernel: ivtv1: i2c attach to card #1 ok [client=wm8775, addr=1b]
Aug 26 20:05:20 mythtv kernel: tveeprom 4-0050: Hauppauge model 26582, rev F0B2, serial# 9486064
Aug 26 20:05:20 mythtv kernel: tveeprom 4-0050: tuner model is TCL M2523_5N_E (idx 112, type 4)
Aug 26 20:05:20 mythtv kernel: tveeprom 4-0050: TV standards NTSC(M) (eeprom 0x08)
Aug 26 20:05:20 mythtv kernel: tveeprom 4-0050: audio processor is CX25843 (idx 37)
Aug 26 20:05:20 mythtv kernel: tveeprom 4-0050: decoder processor is CX25843 (idx 30)
Aug 26 20:05:20 mythtv kernel: tveeprom 4-0050: has no radio, has no IR remote
Aug 26 20:05:21 mythtv kernel: ivtv1: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
Aug 26 20:05:21 mythtv kernel: ivtv1: Encoder revision: 0x02050032
Aug 26 20:05:21 mythtv kernel: ivtv1: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
Aug 26 20:05:21 mythtv kernel: ivtv1: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
Aug 26 20:05:21 mythtv kernel: ivtv1: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
Aug 26 20:05:21 mythtv kernel: ivtv1: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB total)
Aug 26 20:05:21 mythtv kernel: tuner 4-0061: type set to 50 (TCL 2002N)
Aug 26 20:05:21 mythtv kernel: ivtv1: Initialized WinTV PVR 150, card #1
Aug 26 20:05:21 mythtv kernel: ivtv: ==================== END INIT IVTV ====================

Any suggestions?

Thanks
View user's profile Send private message
v4l-dvb make error's - kernel-source-2.6.15-chw-2
  pcHDTV Forum Index -> Driver Issues
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin