Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> dtvscan hangs at look for sync
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
dtvscan hangs at look for sync
PostPosted: Wed Aug 30, 2006 11:38 pm Reply with quote
MasterC
 
Joined: 28 Jun 2005
Posts: 23




Running Gentoo, 2.6.17, HD-5500, using OTA antenna and DVB drivers:
Code:
uname -a
Linux mythslave 2.6.17-gentoo-r5 #5 Fri Aug 25 13:20:03 MDT 2006 i686 AMD Athlon(TM) XP 2500+ AuthenticAMD GNU/Linux


here's the error:
Code:
./dtvscan -d 0 -fx
dtvscan ver 1.0.3 - by Jack Kelliher (c) 2002,2005,2006
channel = 2
channel = 3
channel = 4
channel = 5
channel = 6
channel = 7
channel = 8
channel = 9
channel = 10
channel = 11
channel = 12
channel = 13
channel = 14
channel = 15
channel = 16
channel = 17
channel = 18
channel = 19
channel = 20
channel = 21
channel = 22
channel = 23
channel = 24
channel = 25
channel = 26
channel = 27
channel = 28
Signal: 99
look for sync


I've also got another HD card (AverTV A180) and a Hauppauge PVR-500 in the machine, so any hints on rolling the HD5500 along side those cards would be much appreciated. Here's my lsmod:
Code:
Module                  Size  Used by
i2c_viapro              7316  0
ehci_hcd               25992  0
uhci_hcd               19596  0
cx88_alsa              10568  0
snd_pcm                66440  1 cx88_alsa
snd_timer              18692  1 snd_pcm
snd                    38584  3 cx88_alsa,snd_pcm,snd_timer
soundcore               7008  1 snd
snd_page_alloc          7688  1 snd_pcm
cx8800                 27340  0
wm8775                  5068  0
cx25840                23440  0
tda9887                16528  0
tuner                  53292  0
ivtv                  191440  0
cx88_dvb               10436  0
cx8802                  9860  1 cx88_dvb
cx88xx                 57124  4 cx88_alsa,cx8800,cx88_dvb,cx8802
btcx_risc               4296  4 cx88_alsa,cx8800,cx8802,cx88xx
tveeprom               13840  2 ivtv,cx88xx
cx88_vp3054_i2c         3840  1 cx88_dvb
or51132                 9284  1 cx88_dvb
zl10353                 4548  1 cx88_dvb
cx24123                13896  1 cx88_dvb
lgdt330x                8028  1 cx88_dvb
cx22702                 5828  1 cx88_dvb
saa7134_dvb            11588  0
mt352                   6148  2 cx88_dvb,saa7134_dvb
saa7134               106848  1 saa7134_dvb
compat_ioctl32          1280  2 cx8800,saa7134
v4l2_common            14528  3 cx8800,tuner,saa7134
v4l1_compat            12548  3 cx8800,ivtv,saa7134
ir_kbd_i2c              6736  1 saa7134
ir_common              23748  3 cx88xx,saa7134,ir_kbd_i2c
videodev                7040  4 cx8800,ivtv,cx88xx,saa7134
video_buf_dvb           4612  2 cx88_dvb,saa7134_dvb
dvb_core               71080  3 or51132,lgdt330x,video_buf_dvb
video_buf              20164  8 cx88_alsa,cx8800,cx88_dvb,cx8802,cx88xx,saa7134_dvb,saa7134,video_buf_dvb
nxt200x                13956  2 cx88_dvb,saa7134_dvb       
                 dvb_pll                10500  5 cx88_dvb,or51132,cx22702,saa7134_dvb,nxt200x
tda1004x               14724  1 saa7134_dvb
nvidia               4544980  0
agpgart                27824  1 nvidia
via_rhine              19524  0

And for completeness here's my lspci output:
Code:
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0d.0 PCI bridge: Hint Corp HB6 Universal PCI-PCI bridge (non-transparent mode) (rev 11)
00:0e.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
00:0e.1 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
00:0e.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
00:0e.4 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
 (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
00:13.0 Multimedia controller: Philips Semiconductors SAA7133 Video Broadcast Decoder (rev d1)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)
02:08.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
02:09.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)


Any help would be much appreciated on getting the HD-5500 working.

-Chad
View user's profile Send private message
PostPosted: Thu Aug 31, 2006 9:13 pm Reply with quote
MasterC
 
Joined: 28 Jun 2005
Posts: 23




Hello, anyone?
View user's profile Send private message
PostPosted: Fri Sep 01, 2006 10:14 am Reply with quote
nybbler
 
Joined: 06 Jul 2006
Posts: 125




This just got discussed in another thread. Basically the tuner isn't capable of providing signal strength (or if it is, only those under NDA know... *sigh*). Try changing all occurrences of FE_READ_SIGNAL_STRENGTH in dtvscan.c to FE_READ_SNR. Signal to noise ratio works just as well if not better for this application.

Also make sure your kernel includes the 5500 drivers. Easiest way I know to check is to make sure CX88_BOARD_PCHDTV_HD5500 appears in $(KERNEL_SRC_DIR)/linux/drivers/media/video/cx88/cx88-cards.c.
View user's profile Send private message
PostPosted: Fri Sep 01, 2006 11:37 am Reply with quote
MasterC
 
Joined: 28 Jun 2005
Posts: 23




Will do, thank you for the reply. I did a search (even as late as 5am this morning) but didn't find anything, just for kicks, can you point me to the thread where it was discussed?

I'll report back with my findings.

Thanks again!

-Chad
View user's profile Send private message
PostPosted: Fri Sep 01, 2006 11:56 am Reply with quote
MasterC
 
Joined: 28 Jun 2005
Posts: 23




nybbler wrote:
This just got discussed in another thread. Basically the tuner isn't capable of providing signal strength (or if it is, only those under NDA know... *sigh*). Try changing all occurrences of FE_READ_SIGNAL_STRENGTH in dtvscan.c to FE_READ_SNR. Signal to noise ratio works just as well if not better for this application.


Hmmm. I did that, and now it finishes, but doesn't give me any channels (and I do get channels).
Quote:

Also make sure your kernel includes the 5500 drivers. Easiest way I know to check is to make sure CX88_BOARD_PCHDTV_HD5500 appears in $(KERNEL_SRC_DIR)/linux/drivers/media/video/cx88/cx88-cards.c.


And now I'm feeling like an idiot, but not completely yet. I only see the HD3000 listed in that file, but I do get the HD5500 recognized when loading the module (dmesg):
Code:

cx2388x dvb driver version 0.0.5 loaded
CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47,autodetected]
...
cx88[0]/2: found at 0000:00:0e.2, rev: 5, irq: 10, latency: 64, mmio: 0xd8000000
cx88[0]/2: cx2388x based dvb card
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 1 (LG Electronics LGDT3303 VSB/QAM Frontend)...


So, I'm still not sure if it's a driver issue. Maybe I'll just wipe the slate and start over (again) remove all but the modules related to the other cards on my system, and then use the drivers from the downloads section and try again, maybe it's a conflicting module somewhere...

Thanks for the response!

-Chad
View user's profile Send private message
PostPosted: Fri Sep 01, 2006 1:00 pm Reply with quote
MasterC
 
Joined: 28 Jun 2005
Posts: 23




Progress Smile

dtvscan still gives me zilch (although it doesn't hang now, that's nice) but in MythTV I can actually do a channel scan and it works! But now my A180 isn't working Sad I'll have to keep looking. Maybe it's IRQ issues since one works and not the other... Anyway, looks like the HD5500 is solid now.

Thanks!!!

-Chad
View user's profile Send private message
dtvscan hangs at look for sync
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin