Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> Getting sound to work with cx88-alsa
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
Getting sound to work with cx88-alsa
PostPosted: Sat Sep 23, 2006 9:50 am Reply with quote
vrtladept
 
Joined: 02 Sep 2006
Posts: 3




Hi,

I've successfully used the HD5500 card for a few months now, and was trying to enable the cx88-alsa module to capture sound directly with analog mode instead of through the pass through cable. (My audio seems to capture with pops and thought this might be a solution).

I've been able to load the cx88-alsa module as part of my alsa configuration and have the /dev/dsp2 that I specified. I've also checked it with alsamixer and it exposes and single capture control that is not muted and has volume turned up. But all I get when I try and use the /dev/dsp2 in mythtv is static. BTW, I've run lspci -n and verified that I have the [Audio Driver] exposed on my card.

was wondering if anyone here can help. Here's a lot of relevant details about my setup:

Gentoo 2006.0 system running the gentoo 2.6.18-gentoo kernel. I've got alsa and the cx88 drivers compiled as modules using the versions that ship with the 2.6.18 kernel. I'm using the gentoo standard /etc/init.d/alsasound scripts to start alsa on boot and have the following configured in my /etc/modules.d/alsa file:

--------
alias char-major-116 snd
alias char-major-14 soundcore

#Card 1
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-card-0

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

options snd-intel8x0 index=0

alias /dev/dsp snd-pcm-oss

#Card 2
alias snd-card-1 snd-emu10k1
alias sound-slot-1 snd-card-1

alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

options snd-emu10k1 index=1

alias /dev/dsp1 snd-pcm-oss

#Card 3 - CX88-alsa
alias snd-card-2 cx88-alsa
alias sound-slot-2 snd-card-2

alias sound-service-2-0 snd-mixer-oss
alias sound-service-2-3 snd-pcm-oss
alias sound-service-2-12 snd-pcm-oss

options cx88-alsa index=2
-----------

Any ideas? Thanks!
View user's profile Send private message
PostPosted: Wed Sep 27, 2006 7:54 am Reply with quote
nybbler
 
Joined: 06 Jul 2006
Posts: 125




Take mythtv out of the mix. Run TVtime and pipe the sound directly from the PCHD5500 to your sound output device using sox and/or aplay/arecord.
View user's profile Send private message
PostPosted: Wed Oct 04, 2006 5:32 am Reply with quote
pilesofspam
 
Joined: 09 Aug 2006
Posts: 8




I've actually given up on the cx88_alsa module. I finally installed another cheapie tv capture card to capture NTSC, and put cx88_alsa on the hotplug blacklist.

I would have spent more time trying to get it working, but found that the NTSC video capture quality was unacceptable- it seemed bright and washed out, and although I could adjust the brightness and contrast (under TVtime, I left myth out of the mix at this point) to make it better, it never looked good.
View user's profile Send private message
Sound, but not good
PostPosted: Sun Oct 15, 2006 9:41 am Reply with quote
cfr131
 
Joined: 21 Jul 2006
Posts: 13




I have the analog sound working, but the quality is very bad. It sounds like a 56kbs MP3, with lots of compression artificts. I don't know where to look to see why there is compresion occuring.

The other problem is that in Myth, when switching channels, I lose analog sound.

Running Suse 10.1 Latest myth20.8

When the audio fails, the backend give the following error:

Code:
2006-10-15 10:39:20.378 NVR(/dev/video0) Error: DQBUF ioctl failed.
                        eno: Invalid argument (22)
2006-10-15 10:39:26.816 NVR: Only read 1364 bytes of 5456 bytes from '/dev/dsp1
read audio: Success
View user's profile Send private message
PostPosted: Fri Oct 27, 2006 12:34 pm Reply with quote
nk711
 
Joined: 14 Oct 2006
Posts: 3
Location: San Francisco, CA




On the front end, Utilities/Setup - Setup - TV Settings -
Recording Profiles - Software Encoder (v4l based):

in the Live TV setting, last page, make sure it's not set to MP3 for the codec. Change to Uncompressed 48000.
View user's profile Send private message
Getting sound to work with cx88-alsa
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin