Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> no audio when using pcHDTV 5500
Post new topic  Reply to topic View previous topic :: View next topic 
no audio when using pcHDTV 5500
PostPosted: Tue Jan 30, 2007 5:22 am Reply with quote
williammanda
 
Joined: 30 Jan 2007
Posts: 1
Location: Chattanooga TN




I got the latest knoppmyth setup and running with a pvr-150 tuner. Everything was great. I removed the pvr-150 card and tried out my fusion hdtv5 rt gold card. I get video (mythtv) but no sound. I tried the pchdtv 5500 card and the same result...video but no sound. I tried the main sound for the computer at the desktop and I get no sound. So when I am using the 2 digital cards I get no sound on the system at all. When I remove the digital cards I get the system sound back. When I use the pvr-150 I get system sound and mythtv sound. I have looked at my irq's and everything is fine there, all separate irq's. I'm using KDE (since I'm new to linux and no very little about the command line) and I found this handy tool called KInfo Center. It gives me the sound device information.
Without the digital tv tuner cards:
Installed driver:
Type 10: ALSA emulation
Card Config:
HDA NVidia at 0xd5000000 irq 17 (onboard audio)
Audio devices:
0: AD198x Analog (DUPLEX)
Synth devices:
NOT ENABLED IN CONFIG
Midi devices:
NOT ENABLED IN CONFIG
Timers:
7: system timer
Mixers:
0: Analog devicesAD1986A

With one digital tuner card
Installed driver:
Type 10: ALSA emulation
Card Config:
Conexant CX8801 at 0xd4000000 (the digital card takes over the audio)
Audio devices:
0: CX88 Digital (same here, takes over)
Synth devices:
NOT ENABLED IN CONFIG
Midi devices:
NOT ENABLED IN CONFIG
Timers:
7: system timer
Mixers:
0: CX88 (again, takes over)

It seems that the digital card is overiding the onboard audio.
Please advise.
Thanks

I also posted this in the knoppmyth forum and found several other people had the same issue. I have not found any fix for this problem only a work around that doesn't set well with me.
The work around is to blacklist the audio CX88 which means I can't use the analog TV part.
Please let me know of solutions to this problem and be as detailed as possible due to the fact that I am new to linux.
Thanks
View user's profile Send private message
PostPosted: Wed Feb 14, 2007 12:26 am Reply with quote
no_vcr
 
Joined: 14 Feb 2007
Posts: 4




I got this from another bboard. It doesn't completely solve the problem, but it at least gives you your sound card back without blacklisting. Using your favorite editor, add the following lines to /etc/modprobe.d/sound:

alias snd-card-1 cx88_alsa
options cx88_alsa index=1

However, I still haven't got sound from the analog TV broadcast. I know I'm getting something, because when I run this while running tvtime:

"cat /dev/dsp1 > /dev/dsp"

I hear sounds like something from slowed-down magnetic tape, but they definitely correspond to the broadcast. If you figure out how to get sound from the TV card to work, I like to know! My setup is:

HD-5500
SUSE Linux 10.1 (32-bit)
AC97 onboard sound
AMD MT-40 Turion
View user's profile Send private message
PostPosted: Wed Feb 14, 2007 9:49 am Reply with quote
briaric
 
Joined: 22 Dec 2006
Posts: 11




Sound is the item that I pull my hair out in my gentoo installation.

Is ALSA installed in the kernel or using drivers?

Using the options index as you mentioned appears to work for me. You can check card order by doing a

cat /proc/asound/cards

at the shell.


I still am not sure if the options index actually does force the card order since I have had problems in the past. Right now it is work. I am using 2.6.20 of the kernel with ALSA in the kernel. I have tried alsa-drivers in the past and had problems. Others here might be more of an expert on how to set up alsa. I have eliminated the artsd in my kde setup but that involves recompiling KDE without arts which is doable in a source distribution like gentoo. Not sure about knoppix.

--brianr
View user's profile Send private message
PostPosted: Wed Feb 14, 2007 6:57 pm Reply with quote
nybbler
 
Joined: 06 Jul 2006
Posts: 125




OK, step one is to create a file in /etc/modprobe.d containing the line:

options cx88_alsa index=-2

This will keep the cx88 driver from hogging the first /dev/dsp entry

If you have two cards you might need
options cx88_alsa index=-2,-2
instead (note lack of spaces)

Step 2 is to patch the cx88_alsa driver to fix a few interrupt issues. This is covered in this thread:

http://www.pchdtv.com/forum/viewtopic.php?t=1466&start=15
View user's profile Send private message
PostPosted: Wed Feb 14, 2007 7:58 pm Reply with quote
no_vcr
 
Joined: 14 Feb 2007
Posts: 4




> Is ALSA installed in the kernel or using drivers?

ALSA is in the kernel BUT the modules for the 5500 had to be compiled separately, since SUSE likes to tweak the same generic kernel version endlessly instead of just incorporating the latest generic kernel.
This is what I got from /proc/asound/cards:
0 [CK804 ]: NFORCE - NVidia CK804
NVidia CK804 with ALC850 at 0xf7005000, irq 5
1 [CX8801 ]: CX88x - Conexant CX8801
Conexant CX8801 at 0xf4000000

Nothing that unusual there, I think, except that the CX88 has no irq.
The index options did get my onboard sound chip working again, so now it's a matter of getting the 5500 to play nice. Sound hasn't been a problem until I tried to install the 5500, then it became a pain. Linux has major problems with TV and sound cards, it seems.
View user's profile Send private message
PostPosted: Thu Feb 15, 2007 10:36 pm Reply with quote
no_vcr
 
Joined: 14 Feb 2007
Posts: 4




> OK, step one is to create a file in /etc/modprobe.d containing the line:

> options cx88_alsa index=-2

OK, did this.

> Step 2 is to patch the cx88_alsa driver to fix a few interrupt issues. This is covered in this thread:

> http://www.pchdtv.com/forum/viewtopic.php?t=1466&start=15

Did this too, applied both patches and recompiled. Unfortunately, sound still doesn't work. Running mythtv to view an analog broadcast just gives me the picture but no sound, just a whine. tvtime also has a picture but no sound. I've tried attaching the blue adaptor from the breakout cable to the line in of my mobo and the blue plug of the card, but no dice. According to lspci, this card has an audio port, but still no luck with the audio. Looks like I'll have to make repairing my VCR a priority.
View user's profile Send private message
PostPosted: Sun Feb 18, 2007 8:30 pm Reply with quote
nybbler
 
Joined: 06 Jul 2006
Posts: 125




tvtime won't do sound because it isn't made to. To test sound, run tvtime, and once it is running and tuned to a channel, from a shell window run

sox -r48000 -c2 -t ossdsp /dev/dsp1 -t ossdsp /dev/dsp

This just copies the sound from /dev/dsp1 (which should be your pchdtv 5500) to your sound card.

For mythtv, make sure your audio setup is right. You need to set up the analog options on the card to get the sound from /dev/dsp1. You need to make sure sound output is setup correctly, and you need to change the sampling rate to 48000 in recording profiles.
View user's profile Send private message
PostPosted: Wed Feb 21, 2007 1:28 pm Reply with quote
mraggie
 
Joined: 21 Feb 2007
Posts: 2




In the setup options for the pchdtv 5500, there is no /dev/dsp1 just /dev/dsp.
I am running fedora Core 6, kernel 2.6.19-1.1911 64 bit.
Is this still an issue. I am using the built in support. I didn't compile anything. If I am going to have to patch and recompile the module, can someone post a walk-thru for this. It will be a great help to all us n00b's out here

Thanks
View user's profile Send private message
PostPosted: Thu Feb 22, 2007 9:13 am Reply with quote
mraggie
 
Joined: 21 Feb 2007
Posts: 2




My apologies for the above post. This issue I was having really didn't belong in this thread. The cx88_alsa module was not getting loaded. I installed a new kernel module over the default on that came with fedora 6. I was compiled with a different version of gcc. I removed the updated alsa and went back to the default alsa. Now cx88_alsa module is loading correctly. My apologies again.
View user's profile Send private message
PostPosted: Sat Feb 24, 2007 8:44 pm Reply with quote
no_vcr
 
Joined: 14 Feb 2007
Posts: 4




Thanks, nybbler! That worked! tvtime and mythtv now have sound. I forgot to change mythtv's sound input to /dev/dsp1. All that's left is a little fine tuning. Much appreciated!

nybbler wrote:
tvtime won't do sound because it isn't made to. To test sound, run tvtime, and once it is running and tuned to a channel, from a shell window run

sox -r48000 -c2 -t ossdsp /dev/dsp1 -t ossdsp /dev/dsp

This just copies the sound from /dev/dsp1 (which should be your pchdtv 5500) to your sound card.

For mythtv, make sure your audio setup is right. You need to set up the analog options on the card to get the sound from /dev/dsp1. You need to make sure sound output is setup correctly, and you need to change the sampling rate to 48000 in recording profiles.
View user's profile Send private message
no audio when using pcHDTV 5500
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin