Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> No /dev/dvb dir with hd5500 @ 2.6.19-gentoo-r5
Post new topic  Reply to topic View previous topic :: View next topic 
No /dev/dvb dir with hd5500 @ 2.6.19-gentoo-r5
PostPosted: Thu Apr 12, 2007 7:46 am Reply with quote
stephelton
 
Joined: 12 Apr 2007
Posts: 4
Location: Dallas, TX




The title describes me problem pretty well. I have the following modules loaded:

Code:

stephen@s3 ~ $ lsmod
Module                  Size  Used by
snd_seq                50096  0
snd_pcm_oss            25888  0
snd_mixer_oss          18048  1 snd_pcm_oss
nvidia               6836468  0
cx88_alsa              14120  0
cx88_dvb               13828  0
cx8802                 13700  1 cx88_dvb
dvb_pll                16260  1 cx88_dvb
video_buf_dvb           8708  1 cx88_dvb
snd_intel8x0           31772  0
snd_ac97_codec         94112  1 snd_intel8x0
snd_ac97_bus            6144  1 snd_ac97_codec
dvb_core               73896  1 video_buf_dvb
cx24123                15496  1 cx88_dvb
cx22702                 9732  1 cx88_dvb
snd_pcm                63876  4 snd_pcm_oss,cx88_alsa,snd_intel8x0,snd_ac97_codec
snd_timer              21636  2 snd_seq,snd_pcm
snd                    46564  8 snd_seq,snd_pcm_oss,snd_mixer_oss,cx88_alsa,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore              10080  1 snd
snd_page_alloc         11656  2 snd_intel8x0,snd_pcm
cx8800                 31244  0
cx88xx                 60836  4 cx88_alsa,cx88_dvb,cx8802,cx8800
ir_common              29700  1 cx88xx
video_buf              23684  6 cx88_alsa,cx88_dvb,cx8802,video_buf_dvb,cx8800,cx88xx
tveeprom               17040  1 cx88xx
compat_ioctl32          5376  1 cx8800
btcx_risc               8200  4 cx88_alsa,cx8802,cx8800,cx88xx
videodev               25728  2 cx8800,cx88xx
v4l2_common            20736  2 cx8800,videodev
rr2310_00             174624  2


And here's a dmesg:

Code:

stephen@s3 ~ $ dmesg | grep -i cx
cx2388x v4l2 driver version 0.0.6 loaded
CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47,autodetected]
cx2388x dvb driver version 0.0.6 loaded
cx2388x alsa driver version 0.0.6 loaded
cx88[0]/0: found at 0000:05:07.0, rev: 5, irq: 22, latency: 32, mmio: 0xd5000000
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx88[0]/1: CX88x/0: ALSA support for cx2388x boards
cx88[0]/2: found at 0000:05:07.2, rev: 5, irq: 22, latency: 32, mmio: 0xd7000000
cx88[0]/2: cx2388x based dvb card
cx88[0]: frontend initialization failed
cx88-dvb: probe of 0000:05:07.2 failed with error -1


And some relevant portions of my kernel config:
Code:

stephen@s3 ~ $ cat /usr/src/linux/.config | grep -i cx88
CONFIG_VIDEO_CX88=m
CONFIG_VIDEO_CX88_ALSA=m
# CONFIG_VIDEO_CX88_BLACKBIRD is not set
CONFIG_VIDEO_CX88_DVB=m


stephen@s3 ~ $ cat /usr/src/linux/.config | grep -i dvb
CONFIG_VIDEO_CX88_DVB=m
CONFIG_DVB=y
CONFIG_DVB_CORE=m
# CONFIG_DVB_CORE_ATTACH is not set
# CONFIG_DVB_USB is not set
# CONFIG_DVB_TTUSB_BUDGET is not set
# CONFIG_DVB_TTUSB_DEC is not set
# CONFIG_DVB_CINERGYT2 is not set
# CONFIG_DVB_B2C2_FLEXCOP is not set
# CONFIG_DVB_PLUTO2 is not set
# Supported DVB Frontends
# Customise DVB Frontends
CONFIG_DVB_FE_CUSTOMISE=y
# DVB-S (satellite) frontends
# CONFIG_DVB_STV0299 is not set
CONFIG_DVB_CX24110=m
CONFIG_DVB_CX24123=m
# CONFIG_DVB_TDA8083 is not set
# CONFIG_DVB_MT312 is not set
# CONFIG_DVB_VES1X93 is not set
# CONFIG_DVB_S5H1420 is not set
# CONFIG_DVB_TDA10086 is not set
# DVB-T (terrestrial) frontends
# CONFIG_DVB_SP8870 is not set
# CONFIG_DVB_SP887X is not set
CONFIG_DVB_CX22700=m
CONFIG_DVB_CX22702=m
# CONFIG_DVB_L64781 is not set
# CONFIG_DVB_TDA1004X is not set
# CONFIG_DVB_NXT6000 is not set
# CONFIG_DVB_MT352 is not set
# CONFIG_DVB_ZL10353 is not set
# CONFIG_DVB_DIB3000MB is not set
# CONFIG_DVB_DIB3000MC is not set
# DVB-C (cable) frontends
# CONFIG_DVB_VES1820 is not set
# CONFIG_DVB_TDA10021 is not set
# CONFIG_DVB_STV0297 is not set
# CONFIG_DVB_NXT200X is not set
# CONFIG_DVB_OR51211 is not set
# CONFIG_DVB_OR51132 is not set


The problem is that there is no /dev/dvb dir. There is nothing under /sys/class/dvb...

I have analog up and running just fine with mythtv, but I must have my HD content Smile

If anything looks wrong here, please point it out. I'll gladly print some more information if it would help you help me Very Happy

Thanks much...
~Stephen
View user's profile Send private message
Re: No /dev/dvb dir with hd5500 @ 2.6.19-gentoo-r5
PostPosted: Thu Apr 12, 2007 8:47 am Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




stephelton wrote:
The title describes me problem pretty well. I have the following modules loaded:

You don't have lgdt330x loaded, that's the correct demodulator driver. It should load automatically.

Quote:
Code:

stephen@s3 ~ $ dmesg | grep -i cx

Not every line printed out when the drivers load has 'cx' in it. You'd be a lot better off looking all the output of dmesg. Look for where the dvb drivers start to load and then all the lines until they're finished.

Quote:
cx88[0]: frontend initialization failed

Hmm, "failed", that sounds bad! Some sort of problem with the frontend....

Quote:
CONFIG_DVB_FE_CUSTOMISE=y

Let us look at the help text for this option, since it appears there is some sort of frontend problem..

Quote:
Customise the frontend module

This allows the user to deselect frontend drivers unnecessary for their hardware from the build. Use this option with care as deselecting frontends which are in fact necessary will result in DVB devices which cannot be tuned due to lack of driver support.

If unsure say N.

Hmm, "cx88[0]: frontend initialization failed", and "...deselecting frontends which are in fact necessary will result in DVB devices which cannot be tuned". I sense your problem is somehow related to these two things! Smile
View user's profile Send private message
PostPosted: Thu Apr 12, 2007 11:09 am Reply with quote
stephelton
 
Joined: 12 Apr 2007
Posts: 4
Location: Dallas, TX




Thanks for your response. The results of the above printout were from my last iteration of screwing with my kernel config -- i have played around with it a lot.

As for the LG module, it appears to require that "Customize front end" be enabled. However, it wasn't compiled as a module, so I'll give that a shot and see where that gets me.

Thanks again for your reponse, I'll post results here shortly.
View user's profile Send private message
PostPosted: Fri Apr 13, 2007 9:08 am Reply with quote
stephelton
 
Joined: 12 Apr 2007
Posts: 4
Location: Dallas, TX




Compiling/loading that module lead to a /dev/dvb/adapter0 which mythtv picked up as DVB0. I was able to find some expected HD channels on QAM256, but when I try to view them in mythfrontend I can't see them. Nor can I see analog channels at this point - all I get is static.

This is probably a configuration issue though.

And I've changed tuners with the "Y" button...

At any rate, I'm much closer now. Thank you.
View user's profile Send private message
PostPosted: Sat Apr 14, 2007 12:18 am Reply with quote
stephelton
 
Joined: 12 Apr 2007
Posts: 4
Location: Dallas, TX




I'm now watching HD via mythtv. Thanks for your help.

Need to get analog going again, and get the HD channel info... Rolling Eyes

Thanks much!!
View user's profile Send private message
PostPosted: Mon Jul 30, 2007 8:36 am Reply with quote
jeremyrainman
 
Joined: 19 Jul 2007
Posts: 4




stephelton wrote:
Compiling/loading that module lead to a /dev/dvb/adapter0 which mythtv picked up as DVB0.


I'm using Archlinux (2.6.16 or so), and I modprobe'd that module, and that gave me a /dev/dvb/adapter0, but it does not show up in mythtv-setup.
View user's profile Send private message
No /dev/dvb dir with hd5500 @ 2.6.19-gentoo-r5
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin