Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> xine-hd -> channels.atsc under ~/.xine
Post new topic  This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic 
channels.atsc under ~/.xine
PostPosted: Mon Jan 24, 2005 5:46 am Reply with quote
Bill Thompson
 
Joined: 07 Jan 2005
Posts: 28




Now that I have xine working, I find that dtvscan does not work reliably. I tried to edit channels.atsc by hand by listing each channel number on its own line, but that appears to be wrong.

Does anyone have the correct format to edit the channels.atsc files by hand?
View user's profile Send private message Send e-mail
PostPosted: Mon Jan 24, 2005 9:45 am Reply with quote
Ivar
Guest
 




An extract from my ~/.xine/channels.atsc is:

WETA-HD: :26.1 :27: 1:0
WETASD2: :26.2 :27: 2:0
WETASD3: :26.3 :27: 3:0
WETASD4: :26.4 :27: 4:0

(There should be six spaces between the first and second colon. I see that the reply software is deleting some of them.)

The dtvscan found in tools3-v4l-2.4 (in xine-hd-0.8.tar.gz) generates these entries. The dtvscan found in tools-2.6-a generates entries in a different format.
Re: channels.atsc under ~/.xine
PostPosted: Mon Jan 24, 2005 7:51 pm Reply with quote
cmumford
 
Joined: 07 Nov 2004
Posts: 36




Bill Thompson wrote:
Now that I have xine working, I find that dtvscan does not work reliably. I tried to edit channels.atsc by hand by listing each channel number on its own line, but that appears to be wrong.

Does anyone have the correct format to edit the channels.atsc files by hand?

I looked into the source and here is what I found
View user's profile Send private message
xine won't follow channel list
PostPosted: Wed Mar 30, 2005 2:47 pm Reply with quote
joshua
Guest
 




I've got that file in ~/.xine and it appears to be in the right format but xine won't follow those channels. When I try to change the channel it just goes up one and it always shows subchannel 2. For instance: 26.2 to 27.2 to 28.2. I can start it on whatever subchannel I want with
Code:
# xine -C {channel}.{subchannel}
but it still displays subchannel 2 in the UI. Not only that, but it appears the the subchannel that it is actually showing video for is always 1, not 2. What gives? How can I get it to follow the channel list in ~/.xine/channels.atsc, and how can I get it to show the right channel in the UI?
xine channels
PostPosted: Wed Mar 30, 2005 3:10 pm Reply with quote
Guest
 




It appears we will have to wait for an upgrade for it to work properly.
In xine, I use the command line:

xine -C {channel listing say 45.1} dtv:// so it would read
xine -C45.1 dtv://

with xvmc it works perfectly
channels.atsc under ~/.xine
  pcHDTV Forum Index -> xine-hd
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  This topic is locked: you cannot edit posts or make replies.  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin