Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Driver Issues -> Driver installation help
Post new topic  Reply to topic View previous topic :: View next topic 
Driver installation help
PostPosted: Tue Jun 26, 2007 9:11 pm Reply with quote
stinypudding
 
Joined: 26 Jun 2007
Posts: 2




I have an HD5500 that was working great up until about a week, which I believe coincided with a kernal update to 2.6.20-16. Now my capture card isn't working.

When I do a dmesg |grep dvb, here is the output:

ryanr@ubuntu:~$ dmesg |grep dvb
[ 17.040000] cx2388x dvb driver version 0.0.6 loaded
[ 17.040000] cx8802_register_driver() ->registering driver type=dvb access=shared
[ 17.040000] cx88[0]/2: cx2388x based dvb card
ryanr@ubuntu:~$ dmesg |grep cx88
[ 15.576000] CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47,autodetected]
[ 15.668000] cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
[ 15.724000] cx88[0]/0: found at 0000:00:0f.0, rev: 5, irq: 21, latency: 20, mmio: 0xfa000000
[ 16.008000] tuner 0-0043: chip found @ 0x86 (cx88[0])
[ 16.012000] tuner 0-0061: chip found @ 0xc2 (cx88[0])
[ 16.020000] cx88[0]/0: registered device video0 [v4l2]
[ 16.020000] cx88[0]/0: registered device vbi0
[ 16.684000] cx88[0]/1: CX88x/0: ALSA support for cx2388x boards
[ 17.000000] cx88[0]/2: cx2388x 8802 Driver Manager
[ 17.000000] cx88[0]/2: found at 0000:00:0f.2, rev: 5, irq: 21, latency: 64, mmio: 0xf8000000
[ 17.040000] cx8802_register_driver() ->registering driver type=dvb access=shared
[ 17.040000] CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47]
[ 17.040000] cx88[0]/2: cx2388x based dvb card
[ 17.416000] DVB: registering new adapter (cx88[0])

And when I grep cx88, here is the output:

ryanr@ubuntu:~$ dmesg |grep cx88
[ 15.576000] CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47,autodetected]
[ 15.668000] cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
[ 15.724000] cx88[0]/0: found at 0000:00:0f.0, rev: 5, irq: 21, latency: 20, mmio: 0xfa000000
[ 16.008000] tuner 0-0043: chip found @ 0x86 (cx88[0])
[ 16.012000] tuner 0-0061: chip found @ 0xc2 (cx88[0])
[ 16.020000] cx88[0]/0: registered device video0 [v4l2]
[ 16.020000] cx88[0]/0: registered device vbi0
[ 16.684000] cx88[0]/1: CX88x/0: ALSA support for cx2388x boards
[ 17.000000] cx88[0]/2: cx2388x 8802 Driver Manager
[ 17.000000] cx88[0]/2: found at 0000:00:0f.2, rev: 5, irq: 21, latency: 64, mmio: 0xf8000000
[ 17.040000] cx8802_register_driver() ->registering driver type=dvb access=shared
[ 17.040000] CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47]
[ 17.040000] cx88[0]/2: cx2388x based dvb card
[ 17.416000] DVB: registering new adapter (cx88[0])

When I enter mythtv-setup, my card fails to open, when I select DVB v3(which I believe is correct) or pcHDTV.

Can someone help?
View user's profile Send private message
PostPosted: Wed Jun 27, 2007 3:05 am Reply with quote
waterhead
 
Joined: 24 Apr 2005
Posts: 299




You can't access your card in mythtv-setup while the backend is running. Shut it down first, not sure how to do it on ubuntu.

_________________
Mythbuntu 8.04
Intel D875PBZ main board
Pentium4 3.06Ghz
1024GB RAM
nVidia 6600GT
pcHDTV HD-3000
Air2PC PCI
MythTV 0.21
View user's profile Send private message
PostPosted: Wed Jun 27, 2007 1:22 pm Reply with quote
stinypudding
 
Joined: 26 Jun 2007
Posts: 2




I'm having the same errors with the backend not running. Anyone have any suggestions?
View user's profile Send private message
PostPosted: Wed Jul 08, 2015 4:07 am Reply with quote
Nuzzle
 
Joined: 08 Jul 2015
Posts: 5




In order to get it working on the regular kernel, I had to remove any mention of dvb and video from the lib/lib64 directories, download the 5500 driver, make, make install and all was well. I try the same thing with the smp kernel and I get the analog device just fine, but never any /dev/dvb. We offer best quality Electronic Gadgets test papers and Text books and Islamic Apps materials. You can get our Games 100% guaranteed Islamic Devices. Looks like the correct stuff is loaded into /lib/modules/2.6.17-1.2142_FC4smp/kernel/drivers/media/video/ and /lib/modules/2.6.17-1.2142_FC4smp/kernel/drivers/media/dvb/ (by comparing the file names to the modules that are working in my other kernel). Any advice on getting this to work or any known issues with smp as to why it wouldn't work?
View user's profile Send private message
Driver installation help
  pcHDTV Forum Index -> Driver Issues
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin