Log in Register FAQ Memberlist Search pcHDTV Forum Index
pcHDTV Forum

pcHDTV Forum Index -> Installation/Setup -> Confirm broken card or user error
Post new topic  Reply to topic View previous topic :: View next topic 
Confirm broken card or user error
PostPosted: Wed Jul 23, 2008 5:53 pm Reply with quote
othojohnson
 
Joined: 23 Jul 2008
Posts: 2




So I have tried what I think to be everything. I made sure that I am running recent kernels, and have put the card in two different boxes. I installed Mythbuntu (8.04) on the machine I was planning on using for the backend / frontend and the same results appear as on a gentoo box (kernel 2.6.22). The following are the results on the gentoo box. All of the following was executed as root.

Code:

skinny ~ # lsmod | grep ^cx
cx88_dvb               18180  0
cx88_vp3054_i2c         5888  1 cx88_dvb
cx8800                 39148  0
cx88_alsa              16648  0
cx8802                 21380  1 cx88_dvb
cx88xx                 72740  4 cx88_dvb,cx8800,cx88_alsa,cx8802

skinny ~ # lsmod | grep ^lgdt
lgdt330x               10500  1

skinny ~ # dmesg | grep DVB
[   36.423833] DVB: registering new adapter (cx88[0]).
[   36.423838] DVB: registering frontend 0 (LG Electronics LGDT3303 VSB/QAM Frontend)...

skinny ~ # dmesg | grep 5500
[   35.679041] CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47,autodetected]
[   36.004665] CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV [card=47]

skinny ~ # lspci | grep -i cx
01:09.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:09.1 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
01:09.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
01:09.4 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)

skinny ~ # ls -l /dev/dvb/adapter0/
total 0
crw-rw---- 1 root video 212, 4 2008-07-22 14:48 demux0
crw-rw---- 1 root video 212, 5 2008-07-22 14:48 dvr0
crw-rw---- 1 root video 212, 3 2008-07-22 14:48 frontend0
crw-rw---- 1 root video 212, 7 2008-07-22 14:48 net0



After downloading the newest tools package and making the binaries, the following result from dvbsnr (similar results from dtvsignal) as well as from any channel (3, 5, 8, 10, 12, 15, 33, 45, 61 all have ATSC versions). I tried a bunch, and I know that these are good channels, they work on my HDTV. Again executed as root

Code:

skinny dvb-atsc-tools-1.0.7 # ./dtvsnr 8
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 183000000 Hz
video pid 0x0021, audio pid 0x0024
dtvsnr ver 1.0.7 - by Jack Kelliher (c) 2006-2007
channel = 8 freq = 183000000Hz
 dB     -10        0        10        20        30        40
SNR:     |         |         |         |         |         |
SNR: NO LOCK

skinny dvb-atsc-tools-1.0.7 # ./dtvsnr -dvb 0 8
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 183000000 Hz
video pid 0x0021, audio pid 0x0024
dtvsnr ver 1.0.7 - by Jack Kelliher (c) 2006-2007
channel = 8 freq = 183000000Hz
 dB     -10        0        10        20        30        40
SNR:     |         |         |         |         |         |
SNR: NO LOCK


Everything seems to be fine, except for the fact that the utilities don't measure anything, which makes me think that the tuner is broken. Have I missed something? I know it isn't your utilities, as I set the card up right in mythbuntu, and it wouldn't work either.[/code`
View user's profile Send private message
PostPosted: Wed Jul 23, 2008 11:15 pm Reply with quote
xyzzy
 
Joined: 12 Feb 2006
Posts: 225




You could be using the wrong channels, cable vs OTA. Also if there is an analog station being broadcast on channel 8, then the digital version is not boadcast on the same channel! It may show up as 8 on your HDTV because it's remapped, but it can't be broadcast on the same channel as the analog station.
View user's profile Send private message
PostPosted: Thu Jul 24, 2008 9:39 am Reply with quote
othojohnson
 
Joined: 23 Jul 2008
Posts: 2




xyzzy wrote:
You could be using the wrong channels, cable vs OTA. Also if there is an analog station being broadcast on channel 8, then the digital version is not boadcast on the same channel! It may show up as 8 on your HDTV because it's remapped, but it can't be broadcast on the same channel as the analog station.


Indeed it is remapped. Thanks. I should have understood this from the instructions. I found a post on the avsforum
http://www.avsforum.com/avs-vb/showthread.php?t=451563
which pointed to the following for OTA ATSC
http://spreadsheets.google.com/pub?key=p6nKgi12WrqD3G6D1izcsDw

This told me that the HD channels for PBS 8 here are actually channel 29 remapped to 8-*. So this works using dtvsnr

Code:
otho@skinny:dvb-atsc-tools-1.0.7> ./dtvsnr 29
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 563000000 Hz
video pid 0x0021, audio pid 0x0024
dtvsnr ver 1.0.7 - by Jack Kelliher (c) 2006-2007
channel = 29 freq = 563000000Hz
 dB     -10        0        10        20        30        40
SNR:     |         |         |         |         |         |
SNR: 018 =============================


Thanks abunch
View user's profile Send private message
Confirm broken card or user error
  pcHDTV Forum Index -> Installation/Setup
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 7 Hours  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  


Powered by phpBB © 2001-2003 phpBB Group
Theme created by Vjacheslav Trushkin